Problem connecting to Peggy2

edited August 2013 in LED Matrix Kits
Hi,
I've come up against a problem uploading sketches from Arduino (1.0.4) to Peggyv2.2.
I have the Peggy Library the FTDI (2.2.18) driver installed.
Selecting Diecemila board and correct port.

when I upload a Peggy sketch, I get a few random flashy lights and then Peggy goes straight back to its current sketch and Arduino stalls on "Uploading"

I have started using a new computer, Mac OSX10.8.2 and noticed the FTDI driver seems to be qualified upto OSX10.7 so not sure if that is it.

If anyone has any suggestions, please share!

*edit* I've also just broken one of the legs off the ATMega328 chip... this has me wondering if I may have selected the wrong board, I have been trying "Arduino Diecimila or Duemilanove w/ ATmega168"  should have selected "Arduino Duemilanove w/ ATmega328.”

I've reseated the ATMega, but it is missing the reset leg. The current sketch still works (Peggy2RGBDemo) however the reset switch doesn't and I guess this may prevent sketches being uploaded. So I think I've compounded my problems... will need a new chip now...

Thanks

Comments

  • Hi TimL,
    It sounds like you're mostly doing everything right-- I say "mostly," because obviously something is still amiss, or it would be working. :)

    It sounds like the auto-reset circuitry is working correctly, because it blinks for a bit when you try to program.

    So far as I know, there's no driver issue with MacOS 10.8; I'm using 10.8.3 right now. 


    One possible thing to check:  If your Peggy has the Atmega328 chip, you probably need to select the "Arduinio Duemilanove with Atmega328"  option in the boards menu.

    And finally, are you getting any kind of error messages in the Arduino window?
  • Hi Windell,

    Thanks, I think that was it... If you've read my edited post above, you'll see I've added to my problems...

    Might need to replace the chip before continuing...

    Thanks so much for your reply!

    TimL


  • Yes, it is not possible to reprogram the chip if it is missing its reset pin.   If there's still a stub of a pin there, I'd suggest soldering a wire to that stub, and wiring that to the circuit board.
  • yes, may have to do that..

    otherwise it is a new chip... presuamably they are easy to purchase... will I have to reinstall code on it?

  • A genuinely "new" chip is sometimes called a "bare" chip-- you'll need to install the Arduino bootloader on it (using a AVR ISP cable) in order to use it through the FTDI interface.  If you have another Arduino handy, you can do that with the Arduino as ISP method, or you may want to just purchase a prepogrammed chip.   

Sign In or Register to comment.