Installing the 'new' Hatch Fill?
  • Hi there, I saw that there was a major revision for the Hatch Fill extension. I'm trying to install it but it won't work.
    Using Inkscpe 0.91 and this is the error that I get back:

    Traceback (most recent call last):
      File "eggbot_hatch.py", line 1719, in <module>
        e.affect()
      File "C:\Program Files\Inkscape\share\extensions\inkex.py", line 268, in affect
        self.effect()
      File "eggbot_hatch.py", line 1138, in effect
        self.handleViewBox()
      File "eggbot_hatch.py", line 668, in handleViewBox
        if self.getDocProps():
      File "eggbot_hatch.py", line 654, in getDocProps
        self.docHeight = plot_utils.getLength( self, 'height', N_PAGE_HEIGHT )
      File "C:\Program Files\Inkscape\share\extensions\plot_utils.py", line 76, in getLength
        str = altself.svg.get( name )
    AttributeError: Eggbot_Hatch instance has no attribute 'svg'

    Can someone translate this into human language and tell me what I do wrong?

    Thanks!

  • I'm not sure that I've seen that error before. I think that you may not have the right version of plot_utils.py. My version (v 0.4) does not have getLegnth on line 76.
  • Looked into my version (which is in the zip file 'eggbot2.7.1_win ), opened with wordpad and found this: # Version 0.1, Dated January 8, 2016.

    I solved it with the correct version found here: https://github.com/evil-mad/plotink

    No errors anymore...and just did my first Hatch Fill.....WOW what a nice job you guys did!
  • Great-- glad that's working for you. It really is a world of difference, isn't it? :D
  • It sure is , makes live a lot easier! This is a huge improvement for the eggbot.