Axidraw extension

I am using the axidraw extension in Inkscape to drive my drawbot.
My problem is that if I try to draw a 25mm square it comes out as 31mm square.
How can I change the motor resolution to correct this?

Comments

  • If you need to change the software to work with a different kind of plotter, you will need probably want to adjust the page size, resolution, speed, and acceleration values found in the axidraw_conf.py configuration file.
  • If your using Windows and need to modify the scale of what's plotted, you will probably have to set the permissions for the axidraw_conf.py file so you have full control.
    In my setup the file was found under C:\Program Files\Inkscape\share\extensions

    Next open the file and look for "#Machine resolution: Used in converting drawing size to motor steps."
    Muck with the settings until you get the correct scale. I had to reset it to 2500 so the Inkscape 100mm scale matched what was plotted.

Sign In or Register to comment.