Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Egg-bot firmware Problem

edited June 2012 in Egg-Bot
My two week old egg-bot board came with 2.0.1 firmware. Working ok but Pause alwas crashed Inkscape. Up dated the firmware to 2.1.4 and the servo no longer worked. Tried going backwards to 2.0.2 and the same problem, no servo. Also unable to reset the EBB. After a few tries I deleated all the firmware files and went to the WIKI sight and got the 2.0.2 and tried again. After a couple tries I had it working again. Used the HIDbootloader.exe. What will it take to get the firmware to work correctly? Or should I leave well enough alone? Thanks, Carl


  • Hi Carl,
      The older EBB firmware (which ships with the Eggbot) supports all features that are required by the Eggbot extensions for Inkscape, and is known to work well.  So, we do not recommend updating the firmware to the newest version unless you are developing custom driver software and need access to the newer features.

      As for the "pause" issue, I'm not sure what the problem is.   I don't think that I've ever seen Inkscape crash when you press the pause button.   Can you please say what version of Inkscape you are using, and on what operating system/version?  

      Finally, can you please say what problem you're actually having with the firmware?  (Other than the known servo issues with the newer firmware version.)

  • After looking around I found the answer to my 2.1.4 firmware problem. Other's had the same servo problem and 2.1.5 came out and fixed that problem. The other problem I had was the EBB would not reset. The red and green leds would stop flashing for about 2 seconds and then go back to alternet back and forth flashing. Staying in bootloader mode. As to the Inkscape crash when paused, 2.0.2 fixed it for me. I am running Vista. The Egg-bot control said that was an inkscape bug causing the pause crash. I'm running 0.48 Inkscape. As of right now I am running correctly and will leave it at that. I did download 2.1.5 and if I don't get rid of it I won't be able to leave well enough alone. I'll bet the bad words will be flying again. LOL   Thanks, Carl
  • Well, that's an unusual problem with the reset-- I'm really not sure what's going on there.

    As for the crash, that is actually news to us.  There is a known bug in Inkscape that means that the software "cancel" button does not work, but it shouldn't actually crash anything.  

    Anyway, I'm glad to hear that you're (at least mostly!) up and running again.
Sign In or Register to comment.