Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Alpha Clock Five, Error Compiling sample sketches

edited February 2013 in Clock Kits
I'm trying to test out the sample sketches that came with the alphafive library, and encountered error compiling.
Am I missing a library or something? I've just followed the instructions on wiki... I would appreciate any help!

/Users/----------/Documents/Arduino/libraries/alphafive/alphafive.cpp: In function 'byte a5CheckForRTC()':
/Users/----------/Documents/Arduino/libraries/alphafive/alphafive.cpp:753: error: call of overloaded 'write(int)' is ambiguous
/Applications/ note: candidates are: virtual size_t TwoWire::write(uint8_t)
/Applications/ note:                 size_t Print::write(const char*)


  • Hmm.  I just tested all of the sample code, and I don't get that error.   

    Which version of Arduino are you using?  
  • edited February 2013
    Okay, a suggestion.  Open up the library file ( .../Documents/Arduino/libraries/alphafive/alphafive.cpp ) and on line 753, make the following change:  

       Wire.write(0); // start at register 0
       Wire.write((uint8_t) 0); // start at register 0 

     Please let me know if that fixes it.  
  • Wow, thanks, that fixed it, but I've realized that my Arduino is 1.0, which was probably why this happened.

    I have updated Arduino to 1.0.3, and rolled back to the origianal alphafive.cpp, it works perfect, too.

    Thanks for your help!

  • edited February 2013
    Sorry for being trouble, but I'm getting the same error as what's on this thread ( for the AlphaClock.ino, even though the libraries seem to be installed correctly, I can see Time and alphafive from Sketch > Import Library...

  • Perhaps you could try replacing your Time library and then restarting, in case something has gone wrong with it, or it's an older version.  If you're getting the exact same error-- indicating that the Time library is not installed --there has to be something wrong with that library or its installation.
Sign In or Register to comment.