EiBotBoard driver(s) wont install on Win7 x64

edited April 2013 in Egg-Bot

Hi guys,

I've been bashing my head against this for a while now. Tried UBWDriverInstaller_v10.exe, UBWDriverInstaller_v20.exe, and the EBB_inf.zip one.

I can see EiBotBoard as a device in Ports (COM & LPT), but it has that nasty yellow triangle with ! in the middle. Its properties say:

GENERAL:

This device is not configured correctly. (Code 1)
A service installation section in this INF is invalid.
To find a driver for this device, click Update Driver.

PORT SETTINGS:

9600

8

None

1

None

DRIVER:

Provider:       SchmalzHaus LLC

Date:            06/12/2012

Version:         5.1.2600.7

Signer:           Not digitally signed

DETAILS:

loads of hex type crap.

Interestingly, the property 'Install Inf' seems to have a value of C:\Windows\INF\oem19.inf

This is definitely NOT the right name or path for the driver that was installed.


Needless to say, updating drivers doesnt work.

Its also interesting that I could get the EBB into HID bootloader mode (via button presses etc), and the Microchip HIDBootloader could see and flash it without any problems.

The EBB has also sometimes morphed into an Unknown Device, or a COM port, usually COM6 - but it increments by one every time I reset or reinsert the USB cable.

The hardware is clearly fine, theres just some Windows driver type madness going on, hopefully you've seen it before and can suggest a painless solution? Im running rather short of hair... 

I havent had any problems with any other USB devices. System is as follows:

Win7 x64 SP1, AMD 64x2 4200, 2x 1GB DDR2,  ASROCK N68-S UCC (BIOS 1.70), Logitech wired USB mouse, Dell RTD50 wired USB keyboard with smartcard reader.


PS Forgot to add, when I try to install the drivers using USBDriverInstaller.exe from the Inkscape extension dir, it fails with Error code = 0xE0000217

Also turned off driver signing after my first couple of dozen goes, corner of desktop now says 

Test Mode

Windows 7

Build 7601










Comments

  • Would you please try this older driver installer and see if that works for you?

  • edited April 2013

    Hi, thanks a lot for the quick response.

    Just tried that driver, unzipped to the correct Inkscape dir, ran the exe with EiBotBoard off.

    Appeared to install OK, but when EiBotBoard plugged in got the usual 'Device Driver was not successfully installed'

    In Device Manager it appeared as EiBotBoard in Ports,

    Device Status:

    Reinstall the drivers for this device. (Code 18)

    To reinstall the drivers for this device, click Reinstall Driver.


    Which is new, so progress of some sort is being made, thanks. 

    I'll keep trying, do you know if any particular Windows Updates etc are required for all this to work?

    Inkscape works, and can run the extension - it just cant find an EBB.

    Just deinstalled it all, then tried running USBDriverInstaller.exe with the EBB plugged in, in this case it failed with error 0x2


    Discussion of this problem here:

     Why CDC Serial Device installation fails on Windows Vista and 7 ?

    http://www.microchip.com/forums/m488342.aspx



    Had a look at  in the driver dir, it refers to mdmcpq.inf which doesnt exist on my system, I just searched drive C for it.

    Neither does this dir:

    C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_9bb71004e7b8f7ae

    Will keep looking and update you if I get it going, any and all ideas appreciated.
  • Further to this it seems that usbser.sys is not standard with windows anymore, I've tried a couple of different copies I've found but device manager shows Code 1 Not designed for this system.

    Apparently here:

    http://social.msdn.microsoft.com/Forums/en-US/quebecmisc/thread/56315793-9a01-4cf4-8991-24cc749c9d9a/

    and here:

    http://social.msdn.microsoft.com/Forums/en-US/quebeccomponentsforum/thread/9c692513-dd9e-4073-8c6b-92965aa7c616/

    there are others with very similar problems. Cant find the Compaq USB Modem Driver they talk of anywhere else so Im downloading WES7 to get at it.

    That may take some time so hopefully I'll find it somewhere else first.

  • YouFoolishBoy,

    I'm really sorry to hear the problems you are having. Just to clarify some things - usbser.sys is included in recent Windows OS installs (Vista, Win 7 (32 and 64), Win 8 (32 and 64)). The post you linked to above is regarding Windows Embedded, which is a strange beast - it's a very componentized version of Windows that allows an embedded system hardware vendor to select just the Windows components they wish to install on their OEM embedded system. We've used it several times where I work for systems we sell to our clients because the cost per seat is much less than a full blown Windows licence. In any case, I believe the missing usbser.sys is an issue just for Windows Embedded, not normal commercial Windows. I know that I have installed INF files that refer only to usbser.sys under Windows 8 32 and 64 without problems. You won't be able to search for usbser.sys on your C: drive because it is normally contained in container file (.cat? maybe something else) along with lots of other files, and only extracted when it's needed (like when you install the EBB drivers).

    Now, to you particular problem. I have tested the new (v2.0) EBB driver installer on Win 7-32, Win 8-32 and Win 8-64, but I don't  have a Windows 7 64 test system to try it on. Having said that, I have no reason to suspect that it shouldn't work on Win7-64.

    One thing I would try is to plug in the EBB, go to the Devices and Printers control panel, right click on "USB Serial (UBW-based) communications port (COMxx)", select "Properties", then click on the Hardware tab and click "Properties" again, then click "Change Settings", then click the "Driver" tab, and click "Uninstall". Windows should ask you to "Confirm Device Uninstall", and make sure to check the box that says "Delete the driver software for this device". Then click OK. Then reboot your machine.

    Then, before you plug in the EBB again, run the UBWDriverInstaller v2.0, then plug in EBB, and see if Windows is happy with the driver install at that point. (i.e. no yellow triangle).

    Let me know what you find-

    *Brian
  • edited April 2013

    Hi, thanks for the reply.

    The only reason Im after WES7 is to get a copy of either usbser.sys or whatever repository its stored in, I suspect its to be found here:

    C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_9bb71004e7b8f7ae

    Sadly that doesnt exist on my machine, and I cant find either on the net separately, I remember being able to grab various dlls etc from the net for 98, XP etc but no go on this one.

    Im after the repository mentioned above because the EBB .inf uses a call to mdmcpq.inf to get usbser.sys where it needs to go, and it cant find it.

    The driver error says theres an invalid section in the .inf, and device manager says this:

    The drivers for this device are not installed. (Code 28)
    The system cannot find the file specified.
    To find a driver for this device, click Update Driver.

    when it sees the EBB as a Com device

    When it sees it as an EBB it says:

    This device is not configured correctly. (Code 1)
    A service installation section in this INF is invalid.
    To find a driver for this device, click Update Driver.

    Or sometimes:

    Reinstall the drivers for this device. (Code 18)
    To reinstall the drivers for this device, click Reinstall Driver.

    From reading the Microchip forums and various others it appears if I somehow acquire usbser.sys and put it in C:\Windows\System32  C:\Windows\System32
    \drivers and/or in the same dir as the EBB drivers install from, I should have some luck.

    I have a horrible feeling I may end up having to reinstall Windows to sort this out, not a pleasant thought in and of itself; but when I think about all the software etc that'll have to be reinstalled and configured I get a bit of a sinking feeling...

    EDIT:

    Just tried the EBB on a friends XP SP3 laptop as a sanity check, it works perfectly.

    Brian, forgot to say I tried your suggestions (for which Im grateful), with all the EBB drivers available.

    Lead to errors as described above, sadly.

Sign In or Register to comment.