Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

2 flashing columns Peggy 2le

I just fished soldering my Peggy 2le today. I tried different sample codes and all I get is columns Q7 and Q23 flashing all the way up to the second to the top row. Where should I start trouble shooting it?


  • First off, are you getting the same pattern exactly, regardless of the program that is being run?

    And, can you please describe a little more clearly what you are seeing?   Q7 and Q23 are the names of two transistors, which control rows 7 and 23, respectively, starting with row 0 on the top.  Is it these two rows that are showing the issue, or are you actually seeing a problem with two of the columns?   Is the rest of the board lighting, or are these the only rows/columns that are showing any light?
  • Nothing is lighting up but columns 7 and 23 and nothing is lighting up in the top 2 most rows. What is lighting up is flashing and each led seems to be at different brightness's. It is the same no matter what sketch I use.
  • It looks like you might have wire jumpers in both the P2 and SER slots-- is that correct?  If so, please fix that first and see how the rest is behaving.

  • Yes there was I thought I was missing some jumpers. I cut SER so I have P2 with the jumpers. I have the same results.
  • I was messing with the ardunio SDK and when I try uploading something to the board I get.

    "avrdude: stk500_getsync(): not in sync: resp=0x00"

  • The programming error would suggest that the board is resetting, possibly due to an overcurrent event when it's lighting up the LEDs like that.  

    Previously, you said that you were able to program it.  If it can't be programmed, the "CPU" is probably also not in a state where it can correctly light the LED display. You should reload the peggy2_minimal sketch to have a known-good state before going further.  If necessary, gently remove the LED driver chips (U2, U3) so that it will not drive the LED display, so that you can reprogram it.
  • I pulled U2 and U3 I get the same thing when trying to upload the peggy2_minimal sketch. Maybe I never could upload a sketch and just did not look at the output.
  • I just pulled the Atmega328p-pu with another Atmega328p-pu That I have that I knows works and tried uploading peggy2_minimal and I get the same result.
  • By, "the same result," do you mean that it still can't be programmed?
  • Cant be programmed and the LEDs are doing the same thing.
  • Right now, we need to figure out what's preventing programming, because this is a much more fundamental problem than the one with the LEDs. 

    Again, I would suggest that you actually remove U2 and U3 while debugging this-- and do not put them back in --until you are sure that you can get the microcontroller to work normally.    

    Using both sets of jumpers like you did could potentially damage the microcontroller, but that shouldn't be an issue since you've got the extra chip to try.  Are you sure that the extra has the same Arduino bootloader on it?

  • The other one I used has the bootloader that comes with the Arduino Uno 
  • The bootloader from the UNO is not strictly compatible with the one on the Duemilanove (and Peggy 2 default), although I *believe* that it can work if you select UNO as your board type.  Not entirely sure.

    This is starting to get a little more complicated; Do you want to send your Peggy 2LE back to us for diagnosis?
  • Sure I know 2 solder pads lifted up but the connections where not broken 
  • edited May 2013
    If you would like to send it back to us, please use the contact form:

    (Edit: To set up the RMA! You can't fit a circuit board in the contact form.)
Sign In or Register to comment.