Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Bulbdial Clock never worked.

edited May 2013 in Clock Kits
I got a bulbdial clock kit for christmas and I got a bit ahead of myself and put in the chrono dot before setting any leds. my clock hasn't lit up. There is one possible other thing. I need to know if the orientation of a crystal has anything to do with this?


  • Putting in the Chronodot too early should not cause any problems, and the orientation of the crystal does not matter. 

    What stage of construction are you at, presently?
  • I'm at the stage where you have to set up the first ring of lights. But then I went ahead and built the rest of it hoping it would work. Nothing. I'm going to try to upload the firmware again to see if that helps. I've checked all solder joints and tried and tried, but have come up cold. 
  • edited February 2014
    Should there be a capacitor at C4? I don't have one there and I didn't receive the part with the kit so I'm assuming not. Uploading the firmware again did not do anything either.
Sign In or Register to comment.