Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

gEDA on mac

I'm trying (and failing) to get gEDA running on my mac (OSX 10.7.5). I'm new to mac, but I've used linux a bit before. To add to the fun, I'm on my work computer, so I'm not the admin on it.

So I have gEDA downloaded and installed. I can run gschem and pcb. I made a quick schematic and am trying to get it into the pcb program. I tried xgsch2pcb, but that didn't seem to work, so I tried to use the command line gsch2pcb. That's located in /opt/local/bin so if I cd to that directory and run :

wcne-128-154-138-188:bin aresnick$ ./gsch2pcb ~/Documents/Circuits/Schematics/test.sch
gsch2pcb: gnetlist command (gnetlist -q -g gsch2pcb -o /Users/aresnick/Documents/Circuits/Schematics/test.pcb /Users/aresnick/Documents/Circuits/Schematics/test.sch) failed.

where ~/Documents/Circuits/Schematics/test.sch is the path to my simple schematic. I've tried to run gnetlist by itself and that always fails too. Also, I've noticed:

wcne-128-154-138-188:bin aresnick$ which pcb
wcne-128-154-138-188:bin aresnick$ which gschem
wcne-128-154-138-188:bin aresnick$ which xgsch2pcb
wcne-128-154-138-188:bin aresnick$ which gsch2pcb

which doesn't seem good to me, but I don't know how to fix that either. Halp plz?

Also I tried the import schematic feature of pcb, but nothing happened after I did that...


  • Which method did you use to install gEDA, and which of the packages did you install?
  • Seems to be the macports method, and seemed to install pcb, xgsch2pcb in addition to the normal gEDA install.
  • If you can run run gschem and pcb, I'm surprised that you don't seem to be able to find them with which-- do I understand correctly that you can only run them from the directory in which the programs live?  If so, you may need to manually add the /opt/local/bin path to your $PATH.

  • wow, how did I not realize this. Fixed me right up.
Sign In or Register to comment.