Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

ISP 2.0 With UNO - Error

I'm running an UNO with the ISP Shield 2.0 on top and `1.52 of the IDE.  I select Comm2 and the board Arduino Uno.  Then I upload ArduinoISP sketch.  At that point the Pulse light is flashing.  I install an Atmega328 (has Uno bootloader) chip in the ZIF socket.  The Hello light is ON.  I choose the Blink sketch.  I change the board to Arduino Nano and hold down the shift key and upload using Programmer. 
I get the error"
avrdude: stk500_getsysnc(): not in sync: resp=0xff
The Hello, Error, and Pulse light are solid.
I tried the jumper on Override Reset and I get the same error.
I also tried it without and with a 10uf cap between gnd and rst and still the same error



  • Hi Michael,
    For a baseline, have you been able to use the ISP shield to burn the bootloader?

  • One thing that you might check: Is the device that you are trying to program exactly the same model as the one that you've selected?     

    The Uno comes with an ATmega328P; make sure that your chip is actually an ATmega328P, and that the Bano selection is also for the Nano with the ATmega328P.
  • Unable to burn bootloader

    The chip is  a ATmega328P.

    I haven't messed with it since this note. i needed a break.  So I'll try it again and see if I missed anything. 

  • One other thing: we recommend using the 0.1 uF capacitor (as currently included with the kit).  If you use the 10 uF cap, you need to edit the programmer sketch to account for the longer time constant with that big capacitor.  


    See also:
  • Still get the same thing. I put the .1uf between RST and GND.   I can't get it to burn the bootloader. 

  • edited September 2013
    There's not a lot here that can go wrong. You *need* the reset override to be enabled, the capacitor in place, the chip oriented correctly in the ZIF socket and locked down, and power applied. If you've done all of that, and are sure that those portions are all good, what remains is most likely a bad connection somewhere-- and there aren't a whole lot of those to examine.

    So, carefully check every pin on the bottom side of the shield, and make sure that there are not any dry, missing, or cracked solder joints.

    For testing, Double check that

    1. You've programmed the Uno with the ArduinoISP sketch, and see the pulsing on the "pulse" LED.

    2. You have autoreset override selected

    3. 0.1 uF cap between RST and GND.

    4. Board selected is an appropriate type (nano w/328P seems to work fine on the ISP shield ZIF socket)

    5. Programmer selected as "Arduino as ISP"

    6. Your shield is raised up very slightly off of the Uno, so that there's no electrical connection between the USB
    socket and the ISP10 connector on the shield. (Or, use a piece of thick tape over the USB connector.)

    And then select "Burn bootloader."
  • I can't tell much from the picture-- it's really small --but I can see that auto-reset override is not enabled.  I cannot see which pins the capacitor is connected to.
  • I had tried it before with and without the Override selected.  Also did the steps above and the same issue.  I examined all the connections with a 16x loupe and a blown up macro image.  All solder joints are great.

     I tried all the steps above and still the same error.
  • Well, darn.

    I have tried this configuration here (exact, so far as I can tell), and did not have any trouble getting it to work.  So at a minimum, I would expect that what you are trying to do *should* work.  And that leaves two things left to go wrong: hardware or software.  From what you've described, it sounds like you're pretty sure that both are checked out pretty thoroughly, but there still has to be *some* reason that it's not working. 

    One thing that you might consider is sending it back to us to examine it-- if we could verify that the hardware is working, then at least you'd be able to focus on the software configuration to narrow down where the problem could be.
  • I made some edits to the wiki in the first section to point out what will work in the most basic format.

    I HAD to put a .1uf cap in RST and GND to get this to work automatically.  Even then, what worked (for me) was as follows:

    Load Arduino as ISP, disconnect Arduino

    Connect ISP Shield to Arduino, connect Arduino back to PC

    Run through the install as normal.

    Charge $5 for anyone that wants their 328 programmed.
Sign In or Register to comment.