Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Peggy 2 novice having problems with Peggy Draw 2

edited July 2012 in LED Matrix Kits
My son and I build a Peggy 2, but we are total software ignoramuses. I installed Processing, Arduino, and Peggy Draw 2. I have figured out how to making animations in Peggy Draw 2, and I believe I am saving them. When I try to run any of our animations, no matter what it is, I get an error message "Unexpected char: "i"" I have not succeeded in getting any of the frames we have drawn to play on the actual peggy. 

Because of my inexperience, I have no idea what any of this means, or what to do. I would appreciate any help--my son is a little disappointed that we have built this wonderful thing but can't make it do anything. 

(Also, each time I save an animation, it saves as peggyprogram.pde. I change, the name, and when I change the name, it insists that i put it in a folder with the new name. Is that normal and OK?)

We have also tried to use the static drawing examples with the arduino program, but when I try to verify those, I get a message that says "Peggy2 does not name a type" 

Because of my inexperience, I have no idea what any of this means, or what to do. I would appreciate any help--my son is a little disappointed that we have built this wonderful thing but can't make it do anything. 

Thanks for any help. 


  • Hi David,
      It would be helpful if you would ask for assistance *before* getting to the point that you conclude that you can't make it work or that you feel that you need to tell us repeatedly that your son is disappointed.  We can make it work, but it's a lot easier (for everyone) if you ask for help before you get frustrated.

    The "Unexpected char: "i"" error *may* indicate that you tried to open up the Arduino program that you generated with Processing.  Is this possible?  If so, open the file with Arduino and try again.  Until very recently, all Arduino files were saved with file extension ".pde" --this has been a source of confusion, especially now that ".ino" is recommended.  

    Regardless of the extension type, Arduino will *always* insist that a new file should go in a like-named folder.  Allow it to assist you with this process.

    The "Peggy2 does not name a type" error means that you do not have the Peggy2 library for Arduino installed.   You will need to install this before any Peggy program will work, whether or not it was generated with PeggyDraw 2. 

    * Download the Peggy2 library for Arduino, here: 

    * Install the Peggy 2 library: Unzip it, and place the resulting file in your Arduino libraries folder.

    * If you have trouble locating your libraries folder, look for the "sketchbook" folder location in Arduino preferences.  This is a folder, usually named "Arduino," somewhere on your computer system.  If there is not a folder named "libraries" (all lower case) in you sketchbook folder, make one, and put the library there.

    * Restart the Arduino program after having done so.

    Please let me know how it goes.  If you do come across additional difficulty, we're here to help.
  • I actually was also having this problem, however now I am getting this message

    Binary sketch size: 1922 bytes (of a 30720 byte maximum)
    avrdude: stk500_getsync(): not in sync: resp=0x00

    Any Suggestions?
  • Hi tnaik01, 
    This is not actually a related issue.  The "not in sync" error likely means that your Peggy is not connected to your computer, is not powered on, or has some other kind of hardware issue.  Check your connections carefully, and make sure that everything is set up correctly.  Try also just programming some of the example sketches before branching out to use the PeggyDraw.  

    If you have continued difficultly, please start a new forum discussion and describe the issue and your setup to the best of your ability, please. :)
  • Windell,

    I've actually used Peggy Draw before and have programmed some of the example sketches, and they worked fine. I actually wanted to re-install everything onto a second computer, and some how things aren't working as smoothly as the other computer I was using. I wanted to use the second computer because it was closer to where I was working.

    I felt it was a related issue, because with the old Arduino 1.0 I could use .pde files, but even if I go back and re-download the Arduino 1.0, it won't work with the Peggy Draw software anymore, even on my old computer. I still get that "Peggy2 does not name a type." error, of which I haven't experienced before.

  • - An error like "peggy2 does not name a type" means that the Arduino software cannot compile the sketch; typically because you haven't installed the Peggy2 library.   In our tests here, programs generated by Peggy Draw 2 can be opened in Arduino 1.01 and compile correctly (so long as the library is installed).

    - An error like "not in sync" means that the Arduino software was able to compile your sketch fully and completely, and is unable to connect to the external hardware. 
  • Windell,


    Believe it or not, I just was being silly and forgot to install the driver for the FTDI cable on the new computer. SMH, I apologize for disturbing you for this, sometimes my brain turns off.

    Thanks again!
  • HI I think I had some related problem.

    I had installed the Peggy2 library (I can run the example on Peggy2 successfully)

    Then I drew some animation and open it with Arduino, but it shows error like

    " AnimationFrames" doesn't named a type

    Don't know where goes wrong!
  • It looks like you opened the PeggyDraw2 program itself in Arduino, rather than the actual animation file that you generated with it.    The animation file, called PeggyProgram.pde, is normally located in a folder inside the PeggyDraw2 folder.
  • edited October 2012
    Thanks A lot. It works!

    But I got a new problem. Some bulbs were out of control, I didn't draw it at some frames, but it still glowing

    not sure which part going

    Ps. Those error bulbs were on the same row, and also brighter than other bulbs
  • Is your Peggy 2 built with the "SER" option or the "P2" option?  If the "SER" option, you'll need to edit the one line of your PeggyProgram to use the correct library.   If not, see if the same thing happens with the Peggy2 sample programs.
  • edited October 2012
    Sorry I am not sure what's "SER" and "P2" mean...

    But I can say the error line also went wrong during testing with Peggy2 example

    The top line of green part was brighter than other row
  • Assuming that you have the current version of Peggy 2 (2.3), there are four option jumpers on the circuit board that select how the matrix is wired up, the option jumpers shown on page 3 of the instructions. 
  • Yes.I just bought this panel few weeks ago.

    I looked the instruction, and checked my panel, jumpers were installed on JP3 & JP4

    Is this setting correct?
  • Yes, that's the correct default setting. 

    Now, I'm not sure what "The top line of green part was brighter than other row " means.
  • edited October 2012
    Ah-- I was able to see the source code of your comment there, where you linked to a youtube video.  Do I understand correctly that you've left several rows unpopulated there? 
  • edited October 2012
    Yes  I left several rows. Was that cause the error?

  • The solution is to reprogram the Peggy 2, such that it does not try to light up the unpopulated rows of LEDs.  To do this, open up the Peggy2.cpp file from the library.  Find the two sections that contain a "while (j < 25)" part, and change those to skip the rows that you've left unpopulated.  The best method would be to make it so that it needs fewer total trips through that loop-- doing so can actually make the display brighter.
  • Got it.I will populate every rows, thanks.
This discussion has been closed.