Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Error in inkscape when trying to control EB

edited December 2013 in Egg-Bot

Happy Holidays,

I just installed a new computer, running win 8.1. I downloaded inkscape and installed that. I downloaded the EB drivers and installed those (when I did, the EB stopped showing as a problem in the device manager, so that install seemed to be good. I then installed the EB extensions to Inkscape. And then I ran Inkscape and clicked on the Eggbot\Eggbot control menu item. That generated a "Runtime error" in inkscape. And "this application has requested the runtime to terminate in an unusual way".

The green light on the EB board flashes once, then stays on for about a second and repeats.

Any thoughts as to what I screwed up?



  • Hi Fletcher,
    I have heard of a similar error twice before-- neither in the last 12 months --and I wasn't able to get any debugging information about what could have caused it in either case. So, I am sorry for the trouble, and you very likely aren't doing anything wrong, but have some kind of rare configuration that somehow conflicts with either Inkscape or serial communications through python. 

    Here are a few things that you might try, that might help point us towards a solution:
    * Please see if the error persists if you try to plot a blank document to the Eggbot.  
    * See if other (default) extensions are working correctly.  One way is to select Extensions>Render>Gear and click "Apply," and see if that works correctly.
    * See if other Eggbot extensions that *do not* talk to the Eggbot are causing a crash as well.  Select Extensions>Eggbot>Strip Eggbot Data, and see if that crashes.   

    Also do you happen to have a custom Python version installed on your system, and/or have you changed the system %PATH% variable in a way that might affect Python use? Inkscape ships with a private copy of Python which usually gets called (in a separate process) when a Python-based extension (like ours) is executed. 
  • edited December 2013


    The funny thing is that I just put in a new motherboard and this is still a fairly clean installation.

    The Gear extension rendered a gear just fine.

    The Eggbot extension to strip data appeared to work.

    If I try "Name Poem" it too crashes. But the other extensions seem to work.

    I believe to plot it out, I need to get past the Eggbot control menu (which I think has the plot option .)

  • I also noticed that if I just type text and hit "Post Comment" (at least in IE 11), it says that I am missing the "body" - so I go into html mode and add it. But someone who isn't as conversant with html might not understand the error or know how to fix it. Just a heads up.


  • OK-- thanks!  Very interesting!  

    If the "Name Poem" too is crashing, then this likely isn't a machine control issue, but could be a matter of text handling (or something similar).  We do know of a related issue, specific to Inkscape 0.48.4, that was causing a similar crash on Linux, but we have not heard of any trouble on Windows.

    Two things that you could try at this point: 
    1. Download and (manually) install this updated version of our extension: To manually install the extensions, copy the contents of the ZIP archive to (Program files)\Inkscape\share\extensions\

    2. Try the previous version of Inkscape, 0.48.2, which is available for download here: ;
    (Note that if you re-install Inkscape, you will need to re-install the Eggbot extensions as well.)

    If either of these fixes does allow you to operate the Eggbot without crashing, we'll update the installer accordingly.

  • edited December 2013


    I tried option #1 and am not getting the error anymore. I will try to do some more testing, but I probably won't get much chance until after Christmas now.

    Ok, I went a little further and it can't find the serial port. But device manager shows a USB Serial (UBW based) com port on Com3. So not sure what I need to do to tell it to look there. The MB has a Com port (COM1) which is also showing. I will do some more testing and look on the forums for tips on this issue. But at least the main issue is fixed.

    And the problem with having to specify the body html tags still exists and edit not saving (unless I use html mode).... But I can live with those.

    Thanks again for all the help!

    Happy Holidays!


  • Hi Fletcher,
    Thank you again, that is very helpful (and confirms that the "crash" bug is in fact a known text-handling bug in the latest Inkscape version).  

    I am sorry for the continued trouble with the Eggbot connection; I'm not yet sure what the issue could be, but I will look into it further.  We are not having any trouble connecting here from Windows 8.1, and should be able to (and in nearly all cases, does) find the port automatically. 

    On the forum issue: I've just updated my Windows machine to 8.1 so that I can get a look at this for myself.

  • Windell,

    Ok, after way too much work (reinstalling windows, etc.) I tracked it down as follows:

    1) It appears that the USB 2.0 ports do not like the eggbot - when I switched to the 3.0 ports, it worked better.

    2) You were right about using the older version of inkscape .48.2 works, along with the eggbot extensions you sent me.

    This is using the 32 bit version on my 64 bit windows 8.1 since I couldn't find a 64 bit version of 48.2. So it might also be related to the 64 bit version as well.

    Anyway, things seem to be working now.

    Happy New Year!


Sign In or Register to comment.