Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

trouble burning the bootloader to atmega 328

edited August 2012 in Microcontrollers

i have been searching the net and trying, i still can't get the bootloader to go on the blank chip....I am usint the Diavolino as my ISP...i keep getting this for the last 2 chips i tried

avrdude: Expected signature for ATMEGA328P is 1E 95 0F
         Double check chip, or use -F to override this check.


hope somebody can help...i am pulling my hair out


  • Can you say what signature you *are* getting?
  • doesn't say anything....i am stumped
  • use -F to override this check


    how do i over ride the chip?

  • There is supposed to be a line above that one, saying what it actually read-- the "expected signature" line always follows that if the value is wrong.  It should be something like "avrdude: Device signature = 0x1e9514  .

    You may need to just scroll up a line to see it.  

    If you're doing this from within the Arduino IDE, you may need to turn on verbose mode in the preferences.
  • You *do not* want to override the check.  This is a *symptom* of something else wrong, not the cause of the problem.
  • there is no other line about it....I forgot to say instead of crystal and caps, i'm using a 16mhz resonator....but i also tried another chip using the build in 8mhz osc.....
  • there is no other line...just what i posted
  • Do you have the verbose option turned on?
  • And, to be clear, you are *not* reporting nearly enough information here to figure out what the problem is.  I can give you a list of things to check (like, for example, that your target chip actually is an an ATmega328P), but until you can see the actual error, it's pretty hard to guess what might be wrong.
  • ok ...i am using arduino IDE 0023 version....using Diavolino as ISP....wired the breadboard, just like on your tutorial or the one on the Arduino site....i put the sketch ArduinoISP on the Diavolino...i selected Arduino Duemilanove or Nano w/ATmega328.....then run Burn Bootloader with Arduino as ISP...what is the verbose option? 
  • Exactly what chip are you using?  Are you certain that it's a '328P, not just a '328?

    The verbose option, as I said, is in the Arduino preferences. 
  • i am using a atMega 328-PU


  • Yes, that would be the problem right there.  That's actually a different chip, with a different signature, from the one supported by Arduino.

    You can work around this by changing the expected signature in your avrdude.conf file, following the instructions from this thread:
  • thanks for the help
  • Hey Windell, thanks for all the help you gave early in the AM.....such an easy fix....just in case someone needs this


    In case anyone else has this problem (which by odd coincidence I had tonight), this is what I think the problem was and an easy solution:

    If you have a 328-PU in place of the normal 328P it has a different signature byte. Functionally it's the same chip but AVRdude won't recognise it.

    Easiest fix is to find your avrdude.conf file and in the entry under ATmega328, edit the line:


    Thanks Again

    signature = 0x1e 0x95 0x0F;

    to read:

    signature = 0x1e 0x95 0x14;

    The former is the sig for a 328P the latter for a 328.

    Works like a charm after that.

    Obviously you might want to edit it back again after.


  • Incidentally, if some of your wires are loose, you can get exactly the same error even with the correct chip... I mean, so I've heard. ;)

Sign In or Register to comment.