Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Peggy 2 RGBW Blue LEDs not lit

edited August 2012 in General
Hi - newbie here. 

I just finished assembling the Peggy 2 and powered it on to discover a couple of issues. 

1. All the lights come on except blue (I have them configured in 2x2 squares, starting at the upper left with W(UL) R(UR) G(LL) B(LR). 

2. The third and fourth rows (from the top) are very bright, while the rest of the rows are all somewhat dim (again, none of the blues are lit).

I've tried cranking the dimmers (forget what they're called) clockwise several times (is there a hard stop? they just kept spinning), and all the lights got a bit brighter - still not very bright, and nowhere near as bright as rows 3 & 4.

I tried removing one LED driver, then the other (same with the demultiplexers) and then swapping their slots. When certain chips were removed a portion of the board would not light, but no amount of moving things around made the LED's any brighter.

I'm not sure how to troubleshoot this further.

I appreciate any help. Thank you!


  • Two initial questions:

    1. Have you reprogrammed the Peggy at all?
    2. Have you selected the "P2" or the "Ser" configuration option?
  • Good questions.

    2. The board is P2 config
    1. I have not done any programming as I had thought the default was to light all the LEDs as a test (is that wrong?)

    If you think I should upload a new sketch I will ... Just as soon as I receive my replacement demultiplexer since I just broke three pins removing it :(
  • The CPU is indeed initially configured to light up every LED in "P2" mode, so that should be OK.

    With the default initial firmware, I am not aware of any common issue that would cause only blue LEDs not to light.  You might try reflashing it with some of the other basic demo sketches, to see if they work correctly, or if you're still having issues.

    Also, what kind of power supply are you using?
  • I had it on the external plug that was optional with the kit.

    I will try uploading different sketches once I get it going again. 

    Thanks for your help!
  • Interesting ... received my replacement chips and added them to the board one by one as I tested. No difference - however, I pushed down on the LED driver #2 (inner one of the two on the left side of board) and the blue LEDs on the right side of the board barely lit (but they lit). Maybe I need to resolder the socket?

    I have not uploaded any sketches because, well ... I can't figure out how. My Arduino IDE does not seem to recognize the Peggy 2 board.
  • If you are indeed getting some LED light in every row (or at least, almost every row), then the AVR microcontroller is indeed running and scanning between the rows.  If so, it should be possible to reprogram it, and that's a separate issue.

    If pushing down on the socket improves things, then either the chip isn't fully seated in the socket (and check the others, too!) or it's not soldered correctly.  At this point, a soldering issue is the most likely type of thing that's going wrong.
  • Thanks, Windell. The chips are all seated well so I will see if I can re-do the joints on the sockets.
Sign In or Register to comment.