Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Can't get USB connection

edited February 2014 in Egg-Bot
After reading (carefully) the instructions I attempted to get a USB connection to my WindowsVista 64bit computer.  After several failed attempts I went to Device Manager as it says in the instructions when using vista.
I went to Device Manager. There I clicked on the "Action" Tab and clicked on "Add legacy Hardware". I then clicked on Install the Hardware manually. I then clicked on "Have Disk." I then browsed to find the folder UBWDriverInstaller_v20. In this folder was a file called mchpcdc.inf. I clicked on "open." It then says to click next to start installing the new hardware. I then get the following error message:
Completing the Add Hardware Wizard
The following hardware was not installed:
    USB Serial (UBW-based) communications port
An error occurred during the installation of the device
The date area passed to a system call is too small

As a last resort I tried the version UBWDriverInstaller_v10.  This time it supposedly accepted it and I did not get the error message. Unfortunately, when I went to Inkscape and tried to do the setup it again said "No eggbot on serial port."

What am I doing wrong?


  • If you get the "Unable to find an Eggbot" error message, you should try
    one more time, as it can require two tries after being unplugged. 

     The UBWDriverInstaller v 1.0 should be fine for your computer. 

     You may also want to look at your device manager to see if the Eggbot
    (listed as EiBotBoard -- Ei being german for Egg) shows up there under
    USB devices.
    If you don't know how to get to the device manager, you can find help
  • AS I said in my original question. I already went to Device Manager. On several  occasions it showed up on Device Manager as being present.  But when I run it, for example in inkscape, it says  "No eggbot on serial port."
  • I apologize-- tech support force of habit on where to find the device manager.  I only meant to ask if you could see it in the device manager after installing the driver. 

    You say that it showed up on the device manager "on several occasions."  Do you mean to say that it only intermittently appears there? (I'm trying to figure out if there is any obvious hardware problem.)

    A couple of things for you to try:
    - Try other USB ports on your computer, if available.  (We have heard of several cases where specific ports work better than others-- and some cases where only USB 2.0 ports work, and others where only USB 3.0 ports work.) 
    - If you are using a USB hub, try connecting directly to your computer.
    - Check to see if you have any other software running that may be trying to access the USB ports.
    - Check to see if you have any malware protection software that may be preventing you from accessing the USB ports.

    Please let me know what you find.
Sign In or Register to comment.