Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Alpha Clock 5 Serial Comms

edited March 2014 in General
I'm trying to communicate with an Alpha Clock Five over a serial console.

I am configured for 19200 / 8 / none and get a greeting when I connect:

Hello, World.
Alpha Clock Five here, reporting for duty!
RTC not detected. I don't know what time it is.  :(
Setting the date to 2012. I didn't exist in 1970.
0:00:00 Sunday 1 Jan 2012

However, I cannot seem to get it to respond to any commands.  I'm issuing A0HELLO [enter] which should, by my understanding cause the AC5 to display 'HELLO'.

Am i missing something here?


  • From the docs, you need to send a full 12 bytes of data: "A0HELLO....." to indicate both the text, and the decimals to display. 
  • Windell,

    Thanks.  Tried that.  Still no response from the display.

  • If you haven't yet been able to send a signal or reprogram the clock, it could be the case that there is a physical connection problem.

    You might consider trying to run our example code from within Processing.  That code is tested and works well, and should help to eliminate a connection problem as the issue.
Sign In or Register to comment.