Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

motor can't hold up pen arm

edited March 2014 in Egg-Bot
Hi, I'm having trouble getting my eggbot to plot correctly.  Any time the pen arm is more than 5 degrees off center, the pen falls over.  I turned the current adjust all the way up.  I also tried all the way down.  There is definitely one direction that makes the motor stronger and one that is weaker, but neither is strong enough to hold the pen.  Any pointers on how to track down the problem?



  • edited March 2014

    This sounds like too little current through the motor windings. Too little current could be caused by too low motor drive voltage. Check the motor supply voltage first.
    If OK then adjust the current pot meter.
    Check the holding torque of the "egg-motor" if this is weak as well the voltage to the board is too low. On my bot I can hardly move the egg-coupler with power on (enable motors from the "manual" tab in the Inkscape egg-bot dialog).

    If the "egg-motor" holding torque is OK but not the pen-motor, try swapping the motor wiring so the pen output is driving the egg-motor and the egg output is driving the pen-motor. If the problem moves to "the other motor" the board output is bad, if the pen-motor is still bad the motor (or wiring) is bad.
    Chances are you will find a bad connection (or even incorrect wiring) while performing the above swap.

    Please give feedback on the progress.

    The color of the pen arm motor wiring is brown-green-yellow-red going from the bottom of the board, (Brown is closest to the servo connectors)

  • I would agree with all of those suggestions.  Check to make sure that you're using the right power supply (usually 9V, 1.5 A), and, I'd be curious if you could say whether the egg motor is acting the same way.
  • Power supply is producing 9.25v.  The egg motor is strong.  Wiring is in the correct order.  I reversed the wiring and the problem stayed with the pen motor.  Maybe it's a bad motor?  Can you point me to where I can buy a replacement?  This is my first time working with stepper motors, so I don't have any laying around.

  • Yes; a damaged motor, or (perhaps more likely) a bad wire on the motor.  Carefully check the wires, to see if one of them looks like it might be pinched or broken, to see if there's an obvious way to fix it.  If not, you'll need a replacement motor.  Assuming that this is a brand-name Eggbot, please contact our shop directly about getting a replacement.
  • Hi Todd

    Where in the world are you? I have two spare motors in my drawer. (Plus a spare EBB board).

  • All of the wires look ok.  I was thinking about opening it up to see if the connections are good inside the housing.  Is that something I can do without destroying the motor?  I see it has 4 screws on the back.  If we're already assuming it's dead, then probably taking it apart won't hurt.

    I bought the Eggbot through Sparkfun, so I assume it's brand-name.  I'll contact you guys once I'm done messing around with it.

    Ragnar, I'm in NH, which is usually far away from everybody on the internet.  If you happen to be close by, let me know.  Otherwise I'll just go through the official channels for a replacement.

    Thanks again,
  • Hi Todd.
    I am in Texas - just a little too far from NH to drop it off!
    I am sure the EMSS guys will sort you out - their customer care is excellent!

  • @Todd,
    Yes, Sparkfun is one of our distributors-- Please use the contact form on our website, and we'll ship you a new motor. :)

  • I didn't have an adaptor for UK plugs when I first built my Eggbot, so used a Maplins multi-voltage regulated supply at 9V, 1.4A, which worked fine.  

    However the supply provided gives motor jittering on the pen arm.  The pot was already a maximum, wich both motors easily turned by hand, so no joy there.

    The supplied switch-mode psu seems to be giving 1.5A / 9V as expected.  I really don't want to tie my multi voltage supply to the Eggbot - any advice on what I need to look for in a replacement supply?


  • edited April 2014
    Your supply is probably OK for driving the eggbot. The problem seems to be your current potmeter setting.
    With the pot at maximum the current to the motor is too high - the driver chip protection circuitry kicks in - causing the jittering. Try setting the pot to 11 o'clock position (full travel from approximately 8 to 4). On my ver13 boards this results in a current around 570mA which works nice.
    (Please be aware that the silkscreen print on the board with indicates counterclockwise rotation for increase in current is incorrect.)


    Good luck. Please feedback on results.
  • Hi.

    Just tested my eggbot with a 9V supply, no problems plotting.

  • @Jaqcov:
    It's not clear what the situation is. You may have a bad power supply, or it may just be the case that you need to turn down the pot. If you have the current turned up too high on the pot, the motors will make noises, get hot, and plot poorly.  When the current is adjusted correctly, they typically get warm but not hot, do not make noises, and plot very smoothly.  If you can measure the power output, you'll likely find a properly tuned EggBot drawing 500-800 mA.  If it's drawing a full 1.5 A, you have the motors turned up way too high.

    So, I'd suggest dialing down the current first, and then switching to the other power supply, to see if it's working at the more modest current level.  If you can measure the output voltage, check to see if it's putting out a proper 9 V as well.

  • Sorry for the delay.  Turning the power down worked.  Now I have happy eggbot and pretty eggs (well ping-pong balls).



Sign In or Register to comment.