Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Solved - Stipple file will not completely print

edited April 2014 in Egg-Bot
I'm setup on a MAC with the latest software (MAC, inkscape, stipplegen, etc.) and I can print some of the included files like the US states, pumpkin face, and others. However, when I try to print a file generated by the stipplegen program, it will not completely print. I would say it makes it about half way through. Alhtough, this may not mean anything. I used an sag file from my photo and also used and sag file from the default photo when stipplegen starts up. Below is the error from inkscape. I fyou have any ideas, please let me know.



EBB Serial Timeout.
EBB Serial Timeout.
EBB Serial Timeout.
Traceback (most recent call last):
  File "", line 1403, in <module>
  File "/Applications/", line 215, in affect
  File "", line 286, in effect
  File "", line 552, in plotToEggBot
    self.recursivelyTraverseSvg( self.svg, self.svgTransform )
  File "", line 612, in recursivelyTraverseSvg
    self.recursivelyTraverseSvg( node, matNew, parent_visibility=v )
  File "", line 612, in recursivelyTraverseSvg
    self.recursivelyTraverseSvg( node, matNew, parent_visibility=v )
  File "", line 918, in recursivelyTraverseSvg
    self.plotPath( newpath, matNew )
  File "", line 1108, in plotPath
  File "", line 1281, in plotLineAndTime
    if strButton[0] == '0':
IndexError: string index out of range


  • Hi.
    Could you post a link to the SVG file causing the crash?
    Much easier to debug with a file causing the error than from the error messages.
    What version is the EBB board and firmware?
    You can get the board and firmware from the "manual" tab in the Inkscape eggbot extension dialog.
    Select "Check EBB version" from the dropdown list.

  • I am not entirely sure what is going on here.   It could be an issue with the file-- and I would be interested to see the file to check -- but a serial read error typically indicates a hardware problem. For example, in this case:
  • Thanks for the quick reply. I originally thought that this was a software issue of some sort due to the 'IndexError'. However, I found that this occurs anytime plotting is in progress and I unplug the USB cable. I do this since the cancel button does not work. I was able to print my stipple file on a Windows XP machine (yes, I still have one), so the file must be ok. After reading the link you supplied about the hardware problem, I setup the Egg Bot back on my MAC, but did not use the USB extension that I did on my previous setup. This time it worked fine and would plot the entire stipple.svg file. Cool!!

    Here is the EBB firmware version:

    I asked the EBB for its version info, and it replied:
      EBBv13_and_above EB Firmware Version 2.0.1

    If there is a newer version, I will load that.

    Thanks again for the help.

  • Okay-- great to know that it's up and running, and that it was (same as in the previous case of this error) a USB extension cable that was causing the problem.  

    Since things are working well, we would not recommend switching EBB firmware versions.  There are newer firmware versions, but we are still installing 2.0.1 on new EBBs, and do recommend sticking with that for the time being.  (There are some nice features in the newer firmware, but we are still working to ensure full backwards compatibility.)

    It is true that the "cancel" button does not work in Inkscape-- this is a known issue with Inkscape that is unfortunately not within our capability to change.  However, you do not need to unplug the USB cable.  As it says on the "Making your first plot" page of our instructions, you can pause a plot in progress by using the "PRG" button on the EBB.  (You can also press the "RST" button, to cause an error that will cancel the plot. )

  • Well, the problem is not fixed. It's just inconsistent plotting on my MAC. Sometimes it will stop while plotting my stipple file. I can then go manually control the plotter through inkscape and it works fine. I start it again and it may or may not complete. Small things seem to print fine. I don't have any problems on Windows. The plotting completes every time. I also do not think it is my MAC or its USB ports (I've used different ones). Nothing else connected has any issues.

    MAC version: 10.9.2
    Inkscape version: 0.48
    StippleGen 2 version: 2.02
    EB Firmware version: 2.0.1

    Thanks for any help,

  • A problem I used to have on my Mac was that I had another application (LiveScribe) which would periodically wake up, scan the USB devices, and then poke at any which were of a certain flavour without regard to whether they had the USB VID (vendor ID) for the specific device the application cared about.  It would open an I/O channel to the Eggbot, try sending some data to it, and then give up.  That data it sent would mess up my plot.  And, on Linux and OS X, there's no mandatory device locking -- any process could do that.  On Windows, there is mandatory locking and, unless you take steps otherwise, when you open an I/O channel to a device, no other process can then access the device. (And if another process already was accessing the device, then you cannot access it -- you are locked out.)

    Anyhow, it's always possible that you are seeing such an issue.

  • I'm not sure what is causing the problem.  As Dan says, it is quite possible for something else that accesses the serial port to cause a problem, and the fact that it works on Windows suggests that this is the case, rather than a genuine hardware issue. And... I would have suggested looking at different USB ports next, if you hadn't already tried it.  Do you have any "unusual" software or settings that you might be able to identify?  

    Since you're local, we could also consider testing it here (or exchanging the EBB), on the off chance that it is actually a hardware issue.  There are some subtle differences between USB ports on different computers, and it is conceivable (but unlikely) that there could be an intermittent hardware issue that can only be seen on a mac.
  • I found my problem. In short, I increased my Computer Sleep and Display Sleep time in the Energy Saver of the System Preferences to 2 hours. They were set to 15 mins and my plots were taking much longer. I happen to notice that the plot stopped when my screen saver turned on. Although, it was not my screen saver but my Computer Sleep. Since the change, I have plotted a few things that took some time. The last plot was an svg that contained 5000 points and it took 45 mins to complete.

    I feel confident that this was my problem. Thanks for all the responses. This might be worth putting in the wiki. That is, make sure your computer is not set to sleep during your plot. 

  • Hi.

    When having serial or usb problems on other platforms one trick is install a 'monitor' to see all 'traffic' on the port.
    One such goodie for the Mac; Port_Monitor

    Good Luck
  • >This might be worth putting in the wiki. That is, make sure your computer is not set to sleep during your plot.

    Thank you for tracking this down-- that's very helpful indeed. I've added it to the troubleshooting part of our wiki. :)
Sign In or Register to comment.