Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Eggbot inkscape not responding

edited April 2014 in Egg-Bot

I tried to revive the eggbot for some easter egg fun, however currently I am having a headache, because I cant get it to function as designed. I do know its not a hardware failure, because it does work with putty, and I am sure it has something to do with inkscape sending the version command and then crashing...

Anyone any idea to help me out?


  • The situation that you are describing -- where the Eggbot hardware is working, but yet it cannot connect through Inkscape -- is rare. (We do a lot of tech support for Eggbot kits. If something can go wrong, we have seen it. This is just about the least common thing that can go wrong.)  The most likely situation is that something "unusual" on your computer is blocking access to the serial port. That could be as simple as leaving a putty connection open, it could be anti-viral/malware software on your computer blocking ports, it could be other USB devices, especially ones that take special drivers. (We have seen cases where uncommon USB devices have caused conflicts.) Can you think of anything that might be causing an issue of that type? 

     We have also on occasion heard of intermittent problems due to USB cable or hub issues. These have sometimes presented as Eggbots that show up in the device manager, but can't connect from Inkscape, or which print for a while and then stop. If you have a different USB cable that you can try (or if you are using a hub or extension) you might try to see if anything makes a difference. 

  • I have the same problem, and the solution to this is to install Inkscape no higher than 0.48.2.
    After installing this I had no  problem.
    hope this solves your problem to.
  • Reverting to Inkscape 0.48.2 solved the problem for me. I would be interested in knowing is the problem is with Inkscape, or the Eggbot software.
  • @crippledlord: Which version were you running before?
  • edited November 2014
    I have installed 0.48.2 and the extensions.  Inkscape can see the Egg-Bot because I see the lights flash when I send something to it but the motors will not move.  I was able to update to the latest firmware and my computer states the device is working properly.  I need help. 
  • edited November 2014
    @tabermudes: This is not a related issue; please start a new thread so that the prior participants are not notified by mail every time that a reply is posted. We are closing this thread to prevent further replies here. 

     (And before you open that other thread, please check to make sure that the 9V power supply is plugged in and working. Do you still have lights on your board when the USB cable is unplugged?)
This discussion has been closed.