Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

egg stepper motor jumping

edited April 2014 in Egg-Bot

I just got my egg-bot and was testing it this weekend.
When plotting "longer" images, e.g. the WorldMap from examples, I found the egg motor to be jumping and loosing it's position.

I'm not sure, whether this might be a point, but it seems like the stepper motor is jumping back at some point. This happens sometimes in manual mode too, when moving in small stepps.
The Firmware is updated to 2.3.1 and I already tried to change the current for the stepper motors on the poti.

Any hints on this behaviour?

Thanks in advance


  • Hi.

    What's your speed per step setting? I found anything over 700 would lose steps.

  • @mph:
    Are you certain that it's the motor itself, actually jumping steps?  It certainly should not do so, if the current is properly dialed in. What I'd suggest is that you try to plot a few circles, and adjust the current while doing so.  You will likely see that with the current too high or too low that it will skip steps regularly, and that there's a band in between where it works correctly. 

    That doesn't sound a bit good. I'm not sure exactly what's going on there-- are you seeing major cogging, maybe due to having the current low and trying to overcome the inertia there?
  • edited April 2014

    Windell, good point, I'll try to increase the current and see if that helps. What's the max steps per second you can achieve?

    Would you ever want to plot at those speeds anyway?
    When I try to plot at high speeds the pen arm goes 'haywire'  when hatching
    small moves, like there are 'resonance' in the arm d.t. inertia. To avoid this I align the hatching in the X-direction so the small moves are done by the egg and not the pen arm.

  • Thanks for your suggestions.

    I'm printing at speeds around 50-100 steps / s. No need to hurry :-)

    The odd thing is: this happens if I print designs which are approx. 180 deg.
    The glass is rotated nicely and suddenly it is "set back" around 5-10 deg and the overlapping starts...

    I will try the circle print and adjust while printing. Maybe I can reproduce it somehow.
    Till now I tried it with the Hello World print from examples and adjusted the current then but couldn't get to a point where it happened.
    Btw. might be an usefull info :  I'm using a Mac
  • edited April 2014
    Certainly, the OS should not matter -- my main question, right now, is whether the issue is Mechanical (in your setup) or something else (perhaps an electrical issue, or a glitch in the file that you are plotting). 

    Can you check to see if it makes a difference whether you're plotting one of our example files (e.g., Hello World) or your own design?
Sign In or Register to comment.