Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

RoboPaint unable to connect

edited September 2014 in WaterColorBot
Hello, we finally got ours built. Thank you very much for creating this project.

We've tried several times but no joy. Robopaint v0.7.5, Windows 7

Tried restarting the app and the WCB. I looked over the connections several times and everything seems to be correct. When we plug in power, the brush servo moves slightly then stops. 

I assume the computer should give a little ding sound when the usb device is plugged in but it doesn't. 

Is there a certain number of lights that should be on when we plug in the power? 
There are two lights on. The USB light is flashing fast with just power, slower after plugging in USB cord. The light on the right hand side next to where it says "ICSP" is also on. None of the others light up. 

I don't see any obvious damage on the board. I saw somewhere about adjusting the current. Should we try that?

I appreciate your help. Thank you.



  • Hi John,
    I'm sorry to hear about the trouble.

    The first thing to do is to figure out if the issue is specific to RoboPaint, or if it's something else.  
    - Do you get any kind of response at all within RoboPaint? 
    - Are you able to get the WaterColorBot to respond from within RoboPaint RT or Inkscape?

    If you aren't seeing any response at all, you might check to see if the WaterColorBot shows up in the device manager. It should look something like "USB Serial (UBW-based) communications port (COM...)"   If not, you might try reinstalling RoboPaint -- its installer also installs the Windows driver that allows you to connect to it.  You might try a different USB cable if you have one handy. You might try another port on your computer.  If you are connected through a USB hub, you might try connecting directly instead.

    If the issue *is* RoboPaint specific, then things are a little worse. There have been a few cases that we've heard of where RoboPaint conflicts with something, and will not launch or connect on a given system. I'm afraid that we have thus far been able to  track down exactly what is causing it. If you can confirm that this is specific to RoboPaint, we would love to have your help tracking it down. (There is very little harder than tracking down problems that you can't replicate.) There's more discussion, here: ;
  • edited September 2014
    Thank you Windell,

    I'm fairly certain that it's not robopaint. I'd expect the computer and device manager to respond to a usb device even if there are no drivers. It would still show an unknown device. We tried all three usb ports but didn't try a different cable.

    I'll do some more testing this evening and get something other than robopaint to try out. 

    Could you possibly respond to the lights question and do you know anything about adjusting the current?

    Thanks again Windell

    *update after more troubleshooting

    I've moved to another windows pc instead of the laptop we were using and switched out the usb for the one from my camera that has the same small usb connector.
    I downloaded Robopaint RT.
    I downloaded robopaint for the driver
    The lights behave the same on this PC - usb light flashes quickly, then slowly once you plug it into the computer. Only one other light is on. The computer does not detect anything, nor make a usb device sound, nor report anything new in the device manager.
    Both Robopaint and robopaint rt report that there is no watercolorbot to be found.
  • > Could you possibly respond to the lights question and do you know anything about adjusting the current?

    Unfortunately, the lights have never been a reliable indicator in cases like this. The current is factory pre-set (to a reasonable starting value), and should not be adjusted unless there is a specific reason to expect that it needs adjustment.

    Not seeing the EBB in the device manager is very clear, as is the failure to contact it via RoboPaint RT or Inkscape.  Please contact our shop directly via e-mail (reply to your order confirmation) or use the contact form ( ) to request an EBB exchange.  I'm very, very sorry for the hassle, and I'm glad that you were able to test with the other programs and with the other USB cable to pinpoint where the problem was.
  • Here is more specific information about the cases under which you may want to adjust the motor current:
  • I appreciate your help. We'll try doing the exchange. Until then, WCB will wait patiently for us. 

    Thanks again Windell. 
Sign In or Register to comment.