Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

lxml error

edited December 2014 in Egg-Bot
I have fixed this in the past but for some reason I'm getting nowhere on Yosemite 10.10.1. I cannot use Eggbot or even save a files as dxf. I have tried the instructions, but have yet to successfully get lxml either complied or installed.
Anyone have any work arounds or have solved it? 



  • For Yosemite, you'll need to install a fresh copy of Inkscape (the latest version is 0.48.5) and manually install the Inkscape Extensions. (More info here:

     Do not run the EggBot installer; it has not been updated for Yosemite yet, and has a conflict that will cause the LXML error.
  • Ok Thanks. I will try that next.
  • The same issue. I have all the Eggbot files in place and the Eggbot extensions show up just fine. It is this lxml wrapper issue I can't solve. It did compile last night successfully, no idea why it would do that after not compiling earlier. But it still reports this issue. 
  • @robboz4: We have been running Yosemite since before the public beta, and have not needed to compile or install LXML to fix that error.   

    Starting with a _fresh_ copy of Inkscape 0.48.5, please check to see if the extensions are working.  Try, for example,   Extensions > Render > Gear.

  • HI!

    That looks like it did the trick. I tried the "gears" test to make sure I still had an issue and sure enough the lxml issue was still there. I did a complete new install of Inkscape. Tested with gears and it worked. The  "save as" a  dxf file also worked. I manually moved the eggbot files to the directory and yippee no more lxmx error.

    Thanks for the assistance. I'm sure I'll asking again after the next Apple update. :-)

  • Awesome-- and I apologize for not having the new installer ready yet.  We're working full time on shipping robots right now, and will get back to this soon. :)
Sign In or Register to comment.