Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Need help diagnosing Inkscape problem on a Mac

edited August 2012 in Egg-Bot
Just finished building the Ostrich Egg-Bot this morning and have been trying to get all of the software good to's not going! Would definitely appreciate your help diagnosing what I'm doing wrong.

Here's what I'm running on:
Mac OS X Version 10.6.7

XQuartz (removed X11 and then logged out)

It crashed a couple of times when just opening the application in the Applications menu...but then I opened an example file using Inkscape and it opened.  Interface language was changed to English and then I closed it. I tried opening it the same way and got a "Inkscape encountered an internal error and will close now". The interface language is still English and I can see the example file but it won't let me do anything. It now crashes both ways (opening it directly or by opening a file). Any suggestions?



  • I'm not entirely sure what the problem might be.  That should be the right version of Inkscape, and the current version of Xquartz is XQuartz-2.7.3.  

    One thing to check is to see if there might be an older copy of either Inkscape, Xquartz, or X11 on your computer; please look in both your applications folder and in your applications/utilities folder.  (If there is, it could be the case that your computer is opening one of the old versions when you just ask your computer to open up an existing file.)

    Also, if you can get it open (even for a moment) click and hold the dock icon for Inkscape or XQuartz in your dock, and select "Show in Finder" from the pop-up menu.  That will highlight the actual applications in use, so that you can verify that they are the correct ones. 
  • Thanks for the suggestions. There is only one copy of Inkscape on my computer. I deleted everything Xquartz or X11 and reinstalled Xquartz (just to make sure) then rebooted the computer. When I opened up Inkscape from the Applications folder it asked "Where is X11" and I pointed it to Xquartz.  The same error message showed up (opening Inkscape directly and by opening a file).

    I did the "Show in Finder" and the applications in use are Inkscape and Xquartz.

    Any suggestions? Thanks again for the help.
  • Hmmm.   

    Did you already install the Eggbot extensions for Inkscape?  

    - If so, you might consider re-installing Inkscape (a fresh copy) and see if that fixes it.  It is possible (although as-yet unheard of) that the Eggbot extensions have caused the issue.

    - If not, I'm close to suggesting that you file a bug report with Inkscape, to see if anyone there has suggestions. 
  • Also here is a thread that appears to have some possible solutions for these kinds of issues: 

  • Thanks! I try these solutions and report back to what happens!
Sign In or Register to comment.