Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

ostrich eggbot/ inscape crash

edited December 2015 in Egg-Bot
Aloha! I have an Ostrich Egg Bot (bought in 2013). Trying to bring it back to life after sitting idle for some time. Downloaded the newest inscape (0.91). I am using a Mac desktop. When I try to calibate the pen motor inscape crashes and does not respond. My Mac is seeing the EBB on the USB port. Do I need to flash newest firmware? Do I need older version of inscape? Thank You for your input. - Erik


  • Whoa! I don't think that I've ever seen Inkscape itself freeze or crash from anything EggBot related.

    Can you please describe anything else that might be relevant about the situation? Is it freezing or crashing? Is it taking XQuartz with it, too?

    Which MacOS version? Which EggBot software version (Newest is 2.6.3)?

    Some things that you might try:
    - Unplug the USB cable if it appears frozen-- does that make any difference?
    - Update your version of XQuartz
    - Try a different USB cable
    - Reinstall Inkscape (and if so, the EggBot Extensions)

  • Quartz 2.7.8

    Mac OS 10.11.1 

    Inkscape 0.91

    Eggbot extensions 2.5.0

    EBB firmware unknown (Ostrich-egg model purchased in 2013, red colored board)

    Freezing or crashing, I am not sure the difference. When I go to Extentions/Eggbot/Eggbot control/ then the setup tab, adjusting the pen arm then click apply button ( i have tried other actions such as “walk motor 2’) . I get a pop up window: “eggbot control working please wait…” this window never closes and I get the windows equivalent to the spinning rainbow wheel (spinning clock face). I am still able to move the curser around and click out of Inscape, but inscape will not do anything else. Cancel button does not work. Red button to close window not working either.

    If I try this with the EBB not plugged in I get this: “Unable to find an Eggbot on any serial port. :( “.

    I have tried with a new USB cable

    Quartz is working during the inscape freeze

    I have not been able to find Eggbot extensions 2.6.3

    Unplugged cable during freeze, no change, spinning clock face


  • The "cancel" button for Inkscape extensions has _never_ worked; I'm not sure why they have a button there at all.

    Please download and install the new version of the EggBot extensions for mac, version 2.6.3, and then restart Inkscape. (Version 2.5.0 has never worked on MacOS 10.11.)  

     You can find the new version here:
  • I dowloaded the newest eggbot extensions (2.6.3). Came back with an error window that was exactly like the one in this thread:Mac OSX 10.11.1 eggbot extension 2.6.3 problems with Inkscape 0.91 - Evil Mad Scientist Forums

    I followed the recommendations and replaced the serial folder with the serial folder from eggbot ext. 2.5.0.

    Now I have a frozen insacpe again.  :(

  • Two things to check:

    1. Do your other Inkscape extensions work?  
    Try, for example, Extensions > Render > Gear > Gear...

    2. When your Inkscape is frozen, try unplugging the USB cable-- does that make a difference?
  • Thanks for your help and quick response

    1-I tried extentions> render> gear> gear >Aply button with Live preveiw box checked. I DO have the image of a gear/cog on the screen

    2-unplugging effects no change. all buttons do not respond. I must quit and reopen inkscape 

    FYI since my last post I trashed and then reinstalled inkscape (0.91) and eggbot extensions (2.6.3). so the serial folder has not been touched/moved/replaced with 2.5.0 version  
  • unplugged the board > tried to run the egg motor a few steps. Instead of "inkscape can't find the eggbot on any port" I get the crash instead.
  • This won't solve the main problem here, but I've just uploaded a new version of the EggBot driver (2.6.4) which reverts to the older pyserial version, so that you should not need to copy the serial version from the 2.5.0 release.  Please install this version for further tests. 

    Also, when you try to establish contact with the EBB, please use the "Check EBB version" manual command, for consistency. 

    With 2.6.4 installed, try to contact the EggBot with the USB cable unplugged. Does it still freeze, or give you the "not found" message?
  • I downloaded the 2.6.4. Tried to Check the EBB version using the manual command.> Frozen. I tested the USB plug with an external hard drive and it does show up.
  • edited December 2015
    To summarize what we have so far:
    1. We're looking at a MacOS 10.11.1.
    2. Both EggBot Software 2.5.0 (which does not work on El Capitan) and the current version (2.6.4, which normally works on El Capitan) freeze when trying to contact the hardware. 
    3. Version 2.5.0 did _not_ freeze when the EggBot was not physically connected.

    Does version 2.6.4 freeze when the EggBot is not physically connected? (It seems as though the freeze is related to not handling the serial timeout correctly.)
  • We had one other report of (what we believe to be) this same issue, and were able to get their EggBot up and running with some changes to the software. We'll be publishing EggBot 2.7.0 within the next 24 hours as a beta release, and I hope that you'll be able to give it a try. I'll post back here once the link is up.
  • 2.7.0 is now up, with a Mac installer: EggBot Software: Version 2.7.0
  • My first try was a freeze but i want to double check everything to be sure. (off to work now)Thank you for the sofetware revisions.
    On a seperate note: I am think of a new build using a Smoothie Board and the steppermotors I have on the Ostrich Egg Bot. I dont see any info printed on the motors. What are the model number/brand please, so I can find the power requirements for them. Thanks. 
  • We've updated to 2.7.1 now, with a few bug fixes:

    Specs are here:
    (The most important part is what you already know: we recommend running them with 9 V DC.)

Sign In or Register to comment.