Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Stepper Problems for New User

edited January 2016 in Egg-Bot
I just built up my egg bot - using a mac.

went into the manual tab to test each motor.

servo was fine

walk motor 2 (egg) triggered the pen motor too; walk motor 1 (pen) triggered the egg motor too.

the wiring is all fine, its pretty hard to screw that up, the motors don't feel hot at all
when the motors move its jerky.  i read the wiki and was able to turn down the current, and it didn't do anything, tried to tweak the current some more and damaged the current adjust button

any thoughts on what else i can do?  


  • By triggered, do you mean that other motor was energized (but stayed still) or that both motors moved the same amount?How many steps were you telling it to walk for your test?
  • only motor 1 moves - but it moves no matter if i am telling motor 1 or motor 2 to walk

    motor 2 (egg) is energized but doesn't actually step

    i tried it a few times with different amounts of steps to walk, i tried 5 steps, 10 steps, 30 steps, there was no difference in the action of motor 1 (pen) regardless of the number of steps i tried

  • Would you contact our shop about the possibility of sending your EBB in for a check?
  • sure, I'm in oakland, california so it could get to you folks this week.  thanks so much for your time.  ill hit the link and send a note
Sign In or Register to comment.