Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Some LEDs Not Lighting During Test

edited February 2016 in Clock Kits
Got a Bulbdial kit as a gift, and it looks awesome :D

I am having a problem during the blue ring testing phase. About 1/3rd of the LEDs do not light up during the test. Using my Arduino as a 3.3v power source, and a 330Ohm Resistor to keep the LEDs from burning out, I tested each LED while it was soldered in place, and I can confirm that the LEDs are not burned out. I tried this while the power to the clock was off and they would each light correctly.

I checked for shorts, solder that went between two connections it should not have, etc, and I cannot see any issues visually...

As I was soldering in the IC, I was worried that I might have done it too quickly as it got warm (not at all hot, just a bit warmer than skin temp). Could this be causing this behavior? I can specify the exact LED positions if it helps, but D12, D32, and D42 are a few that are not working.

Oh, another weird thing I noticed, I have my Arduino running a simple LED lighting circuit, but when I plugged in the spare blue LED that came with the kit, it wouldn't light (although it worked fine when hooked straight to power and a 330 Ohm resistor...?). Do these LEDs have a specific minimum voltage they must reach in order to function?

Thanks for your help, hope we can get this working... :(


  • First off, the IC is fine-- if it breaks, it will break completely. 

    Second: the green and blue LEDs won't light reliably until you give them ~3.4 V forward voltage. You shouldn't expect outputs from an Arduino running at 3.3 V to be able to drive them directly.

    Problems of the sort you are describing are due to an accidental connection, a broken connection, or a damaged LED-- they can sometimes be damaged by heat and/or strain on the legs during installation.

    D52 and D62 are also in the group that you are describing-- check those five LEDs to see if any of them appear weak or shorted to lines that they shouldn't be connected to. Test also that each is actually connected to the two lines that it is supposed to be connected to-- test LED6 to LED2, for example, to see that D62 lights.
  • edited February 2016
    Hi Windell, thanks for the quick reply!

    1. Great! Glad to know it's not the IC, as that would be a pain to take out at this point :)

    2. If the LEDs are 'damaged', does that mean they will light when powered directly (as they do), but not when they are hooked to the clock's circuit? When I hook them up to the 5v power source on the Arduino they work fine, and appear bright.

    3. The LEDs which do not light now are: D12, D32, D42, D52, D62, D23, D24, D25, D26, and D21

    I'll double check for crossed / broken connections, but I don't think there are any from what I can see. There looks like a shiny, clear liquid that has come from the solder, but that isn't conductive is it? I also used two different brands of solder that seemed slightly different, would this have any effect on resistance or function?

    Upon further testing, when I try to light D65 by touching the edge of the pad instead of the tiny points of the LED legs that were left after clipping, instead of lighting, D64 lights dimly, does that mean something?
  • It sounds like there is no connection between the line LED2 and the rest of the circuit. Check the soldering at resistor R2, and also at the IC, on the side that faces R2.
  • edited February 2016
    I've spent hours looking at this, trying to touch up any soldering points that may not have been perfect, and there is no change. Any other troubleshooting ideas, like a way to manually connect LED2? When I hook up the 5v+ from the Arduino to LED2, it causes the 'faulty' LEDs to glow dimly, so I think your assertion is correct about LED2 not being connected, but I can't figure out how to connect it. You can feel free to IM or email me directly to resolve this, if you like. If I can't get this working in another hour or two of troubleshooting I'd like to request a return for some or all of this kit.
  • Do you have a multimeter that you can use to check for a connection between two points?  If so, I would check to see if there is a connection from the pin of the IC (it's pin 23) to resistor R2, and to check to see if there's a connection from R2 to the relevant pins of the LEDs.  

    If not, try visually tracing from R2 to the IC (the trace is visible on the bottom side), and to D25 on the top side. You can also try adding a wire directly (temporarily soldering a wire, for example) from the right side of R2 to the pin of D25 there.

    If you would like to send the board to us, for us to look at it, please contact us through our store contact form ( ). [For what it's worth, people take us up on this offer on a regular basis. In almost all cases, we find that soldering one or two missing solder joints solves the problem.]

  • edited February 2016
    Thank you for the kind offer, I will gladly check this and let you know what I find :)

    I think this may have been my fault for not using the right solder as well.. I haven't soldered in years, and I just used what the guy at Radio Shack recommended, it's the 'lead free' stuff, but doesn't say anything about a rosin core. Also, I'd never heard of a 'cold joint' before, and may of my connections look like pictures online of poor soldering technique :(

  • Lead free solder is just fine, provided that your iron gets hot enough to melt it. Newer soldering irons do operate at a higher temperature; if you are using an older iron with lead free, it can sometimes be a little challenging. 

    (And, if your solder is narrow gauge, flexible, and is sold as solder at radio shack, it probably has a reasonable flux core, whether or not it's rosin based.)
  • edited February 2016
    Making progress! So, I accidentally found that the connection between the chip, top pin #6 from the left was not soldered properly. I re-heated that joint and flowed in a bit more solder properly, and now every light works besides D24. When it gets to this one, it lights up several LEDs dimly (not including D24). I will keep trying to troubleshoot this one, any advice would be appreciated.

    Success! I fixed the solder on that particular LED, and now it works! :D

    I would recommend to anyone else having issues, try to make the connection manually not between two points necessarily, but between the component and the hole it should be sitting in using one of the snipped off resistor legs, from the top.

    Thanks again for your help Windell :)
Sign In or Register to comment.