Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,


edited March 2016 in Egg-Bot
Hi, I bought a new ebb board to help rebuild an old eggbot I got off ebay. I got it hooked up today and the steppers seem to work fine, but the servo doesn't move at all. I tried a new hobbyking servo and it is the same. Do I have to install new firmware? I am using inkscape with the 250A installed drivers. Any help is appreciated.


  • We do test the servo output on the EBBs before we send them out, so it should have been working at least in recent history. Double check the orientation, and that you have it connected into the right port on the EBB. You should not have to update the firmware, nor the Inkscape extension. 

    Is the servo acting energized? Does it "jerk" to a new position when you power on the EBB?
  • no, it doesn't respond at all
    it is plugged into B1 with the brown wire toward the edge of the board.
  • edited March 2016
    Can you please check the bottom side of the board, to see if there's any sign of damage (or perhaps a missing solder joint?). Also, check the top side for any loose components or bent pins. 

    Assuming that you don't find anything, please contact customer service directly:
  • Yes, I found a cold solder joint and resoldered it. Now the pen is working properly, but the motors are "jerky", like very low resolution. Is there a setting for this?
  • Which model of EggBot is it (other than old)?

    It is possible that the jerky movement is due to the motor current setting. When energized, the pen arm should be moveable with gentle pressure, but should not "fall over". If it is too hard to move (which could cause jerkiness) then you may want to turn it down a little. 

    Otherwise, try a slower movement setting, to see if it can perform well at a lower speed.
  • I assume it was one of the earliest models. The board was cracked along with the frame. I am now printing a frame from thingiverse to try to put these motors and the new board on because it is falling apart. I think the previous person got it from someone else too because it looks like these aren't the original motors. I tried out the motors on a ramps 1.4 setup and they run smooth there, but seem to be running full step with the eggbot board. By the time I figure this out, I probably could have just bought the new kit. I should have the new frame printed in a couple hours and see what happens then.
  • Is it the version with the clear acrylic frame?
  • No, it is fiberglass, but it looks like it sat somewhere very dirty and got wet or soaked with something so the fiberglass was falling apart. I bought the new board, checked the motors (with a ramps board), so I know that much is ok. I think the rc servo is ok or at least seems to work. There isn't that much to this thing, I set the current (actually might need a little bit more), but the motors still seem to cog very hard like the board is sending full steps. I have checked the motor wiring by the elimination method so I am pretty sure its not that. Is it possible I have the wrong driver installed?
  • Yikes. That doesn't sound good at all. Nothing short of a strong solvent (alcohol, acetone) should be able to affect the fiberglass.

    The EggBot model that you have is actually very little different from the current models. The motors should be compatible with the EBB, and it should all run fine from 9 V DC. It does sound like it could be a current-setting problem.
Sign In or Register to comment.