Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Unwanted lines drawn

edited March 2016 in Egg-Bot
Hi !

I'm an Eggbot newbie, I've performed a few prints only until now but I'm facing always the same issue.

I've unwanted lines drawn on text and drawings :


Any idea what's wrong ?


Windows 10
Inkscape 0.91
Eggbot 2.7.1


  • There are two possibilities that I can see:

    1. Those lines are actually in your drawing. (Eggbot sees all lines, whether or not you do.)  To find out, select all in your drawing (Edit menu > Select all in all layers), and then in your Fill and Stroke panel (Object menu > Fill and stroke), set the stroke paint to "flat color", and in the stroke style tab, select a consistent width (say, 4 px).

    2. Your pen is raising too slow, or you are lowering it too fast. Play with the delays in the timings tab, if this is the case.

    Also, it's not in any official release yet, (and I mention this because you've already done a manual install...) but if you download the latest version of the EggBot source code ("Download ZIP" on this page: ), the new version has a much-improved hatch fill extension.
  • Hi Windell,

    Thanks for your reply.

    I've checked both of your suggestions but the answers are NO.

    Do I have to just replace the Inkskape drivers or to update my EBB bootloader and Firmware ?

    How can I know my EBB version and update it ?


  • None of your software needs to be updated-- this is not a software version issue. Your EBB version is also fine (unless you manually updated it). The suggestion that I made about the new version was only to add the updated version of the fill extension-- you already have the latest version of the main EggBot control extension.

    Would you consider sending the file here for us to test? If so, please compress it (zip file) and send it to us by e-mail. We could check to see if the problem is reproducible here.
  • Hi!
    I tried again and agin, same result every time.

    When I install the files from github I obtain following error :

    Traceback (most recent call last):
      File "", line 1146, in <module>
      File "C:\Program Files\Inkscape\share\extensions\", line 268, in affect
      File "", line 200, in effect
      File "", line 438, in plotToEggBot
        self.recursivelyTraverseSvg( self.svg, self.svgTransform )
      File "", line 498, in recursivelyTraverseSvg
        self.recursivelyTraverseSvg( node, matNew, parent_visibility=v )
      File "", line 498, in recursivelyTraverseSvg
        self.recursivelyTraverseSvg( node, matNew, parent_visibility=v )
      File "", line 554, in recursivelyTraverseSvg
        self.plotPath( node, matNew )
      File "", line 979, in plotPath
      File "", line 1127, in plotLineAndTime
        ebb_motion.doXYMove( self.serialPort, xd2, yd2, td )           
    AttributeError: 'module' object has no attribute 'doXYMove'

    When I install only hatch files it's OK but doesn't solve the issue.

    I'll send you the file by mail.

  • edited March 2016
    If you are going to install the repository files directly (rather than use the latest release), there is an additional requirement, which is to install the new library "plotink", which has the "doXYMove" command.

    You can download the code from , and copy the three files from the "libraries" folder into the Inkscape extensions folder.

    Edit: I apologize for not mentioning this earlier when suggesting that you try the latest version. Sorry!
  • Something also quite strange is that the Lion is plotted twice.

  • I'm looking at the file now.  

    I don't see the stray lines in the file. (I'll keep looking for the cause of that.) However, the lion is indeed doubled in the file-- there are two copies of those vectors, one right on top of the other.
  • I've tried a test print here and don't see any stray lines.  This is a good looking file; clean lines, no defects that I can see other than the duplicated lion head. (On the other hand, it looks like you did not zip the SVG before sending it, which means that mail-handling programs can alter it.)

    It *seems* like perhaps some pen-up commands are being ignored.  

    Some questions:
    Are the places where you get the lines consistent from print to print? 
    If yes, and if you simplify the file to just those elements that are bridged, does it still give the same bridges?
    If yes, can you get the the lines to change or disappear by using a much slower plot speed or increasing any of the delays?
  • Hi!

    I've tried to print it several times, always the same errors at the exact same place, changing the delays did not solved the issue.

    Probably my Eggbot is defective.

    How do you see that the Lion is doubled ????

    I'm not able to detect that issue.

    Thanks for your support

  • edited March 2016
    Given that it is reproducible, I think that this is a software, or at least timing configuration, issue on your computer. While it cannot absolutely be ruled out, I also cannot imagine that any kind of hardware defect that could cause such a specific yet reproducible issue. My instinct is that any EggBot plugged into your computer would behave the same way. 

    I'll follow up by e-mail.
  • (To close this out: The solution turned out to be a matter of setting the pen-up and pen-down heights a bit differently.)
Sign In or Register to comment.