Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Servo moving by itself

edited July 2016 in WaterColorBot
Just got a WatercolorBot and ran into some issues. The motors seemed to be cogging so I went through all the suggested steps to fix and now it's really not working properly. I also checked the voltage and it seems to be correct.

The servo is twitching slightly up and down any time I plug the power in, whether USB is plugged in or not.

When I try to run a paint job

Running MacBook Pro w/ El Capitan with the 2.0 RoboPaint release. I'm hoping I didn't screw things up beyond repair. Thanks for any help.



  • The servo is clearly malfunctioning, as are the stepper motors. However, it's not clear which (if either) are cause or effect here. If you turned up the motor current too much, it's possible that it's pulling down the power supply at peak usage, which could cause the servo to glitch. On the other hand, if the servo has failed, it could also pull down the power supply, causing the steppers to malfunction. 

    Please try the following:
    Check to see if the servo motor is getting hot.
    Try unplugging the servo motor (at the EBB control board), to see if that has any effect on the steppers-- do they work again once the servo is unplugged?

    And, did you adjust the motor current?

    In any case, it's certainly not beyond repair, but it may plausibly need repair. You're certainly welcome to send it back to us for a tune up, but we'd prefer to get things working in place for you, if possible.
  • Thanks.

    - The servo motor doesn't appear to be getting hot.
    - The steppers don't work properly, even when the servo is unplugged from the EBB. After trying to run a job the X stepper seems to be move very slightly but only as long as the USB is plugged in.
    - I did trying adjusting the current to no avail.

    I'm happy to make any necessary repairs or adjustments. Just point me in the right direction. Thanks so much.

  • Please leave the servo motor disconnected for the moment. If you leave the motors on for a while, do they get hot to the touch? As in, not slightly warm, but hot?

    Second: Please try the "preflight" test from the user guide-- with USB and power disconnected, turn the motor winches through the full range of the machine, to test to see if the motion is smooth and consistent. If it is not, then there may be a problem that is independent of the motors and control system.
  • No, the motors have been powered for more than 20 minutes now and they are cold.

    Did the preflight again. The line on the Y motor seemed really tight so I gave it a little more slack. Both seem to be moving freely and smoothly now when turned. I did notice a very slight gap (about 2mm) at the top left X endstop.

    Even so, it still doesn't work.
  • If they are _cold_, then that suggests that the servo motor power is well below what is needed in order to function properly. I'd suggest turning that up until the motors start to engage.
  • Tried turning current up but still only get results like in the second video posted above. When doing nothing, the motors just slightly click. Still not getting warm. Thanks.
  • Interesting. My best guess at this point is that your power supply has failed (is not supplying enough current-- likely dropping the voltage under load). If so, that would explain all three of the symptoms: the motors not getting warm nor having enough power, and the servo not working correctly.  Please contact us directly, and we can get you a new power supply to try.
  • I finally got a chance to try the new power supply and it appears to be working properly. Thanks for all your time!

Sign In or Register to comment.