Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

What's wrong ? there can't affecting any registers on PIC16F1455

edited August 2016 in General
Hello everyone,
I'm B and I'm a student. The vexed problem couldn't make me sleep well. (Oh you must think I am not a good student) I'm certain I'm doing something simply stupid and wrong, but I can't figure it out.
So I'm simply trying to flash an LED, the PIC16F1455 datesheet was there :  (this is for a digital electronics course I'm studying, I wanted to start with PIC's for microcontrollers for multiple reasons) so my classmates will provide an external 1 Hz clock and the first program is simply a "hello world" flash an LED on RC3.  I've tried multiple codes with nothing working, you can even see that in this latest rendition, I've just dropped FFFF onto LATC. I've also tried to replace mnemonics with direct addressing (actually addressing the LATC register instead of calling it by name).  Running it in simulator, NONE of the registers are changing - not even the bank select register, even when I try to address it directly.  This is only one sample code, unfortunately I've tried about ten different renditions and obviously I'm not about to post every single one. So this is only one of many examples.  But I'll happily take input as to what on earth you think I'm doing wrong. 


  • edited August 2016

    #include ""
    ; CONFIG1
    ; __config 0xFFFF
    ; CONFIG2
    ; __config 0xFFFF
    org H'0000' ;makes sure that the flash memory starts at 00
    ;program starts here
    banksel H'0001'
    clrf H'008E'
    banksel H'0002'
    loopy1 movlw H'FFFF'
    movwf H'010E'
    clrf H'010E'
    goto loopy1
Sign In or Register to comment.