Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Unable to connect

edited November 2016 in WaterColorBot
This discussion was created from comments split from: RoboPaint / RoboPaint RT unable to connect.


  • I have no luck connecting RoboPaint v2 beta 3 with Windows 10. When I plug in the WaterColorBot, I do get a COM port eventually appear. And when I run RoboPaint, I do get a brief flyout on the botton-right that declares "Status: Connected Successful 0/1" which then disappears, but the main dialog has the banner with "Couldn't Connect EiBotBoard not found". No luck with RoboPaint RT either. I have tried different USB inputs and gotten COM6, then COM7, still no connection. I've tried various re-installations, reboots, re-install, etc. No go. Any ideas? 
  • edited November 2016
    I've split this topic, as what you are seeing appears to be unrelated to that in the prior discussion. 

    Now, RoboPaint and RoboPaint RT share no code whatsoever, so if you are failing to connect in both that suggests that something else is wrong, possibly unrelated to either. 

    Since you're describing COM6 and COM7, it sounds like you _are_ getting some kind of a connection to the WCB-- can you please say under what circumstances (or in which software) you are seeing these COM names?

    Also, you might try running RoboPaint RT right after restarting, just in case something was still running in the background from RoboPaint.
  • I see COM6 and COM7 appear when I plug the USB cable in, they appear in the Windows 10 USB devices list. I see COM6 from my USB hub, COM7 from the USB on the back of the computer. I can hit "remove device" and then they go away, and they seem to properly reinstall if I remove and re-insert the USB cable from the WCB. So yes, it appears the WCB is doing enough to set up the serial interface. I will try RoboPaint RT start right after reboot    
  • Thank you for following up. 

    I have a few suggestions of things that you might try. First, you might consider trying out the Inkscape-based software for WaterColorBot. It has an independent codebase, and might help to verify that the machine itself is working properly and can communicate with your computer. Second, check to see if you have any software on your computer (anti-malware, firewall, etc) that might prevent you from communicating properly with the USB port. Third, you might try installing the previous beta version of RoboPaint (available at: ) just in case-- Beta 3 is very new, and we do not have as many user reports on it.

    I've contacted the other RoboPaint developers, and we'll see if we can suggest some additional things to try.
  • I was able to connect to COM7 with Putty (a serial monitor utility at 9600 baud). I was able to perform the R command and get "OK", I also ran SM,100,100,100 which appeared to move the steppers properly. And for the V command, I got "EBBv13_and_above EB Firmware Version 2.0.1"

    I don't know if that helps. No luck getting any of the apps to connect yet... still trying.

  • Even when I remove COM7, RoboPaint still claims it "Connected Successfully" (but EbiBotBoard not found). I disconnected my USB hub, and my keyboard, and the same thing. It looks to me like it is connecting to something else besides COM7... since it produces the same result with no COM7 there at all.  
  • edited November 2016
    The "connected successfully" message refers to the backend/API that RoboPaint uses internally; as you note, that's separate from connecting to the EBB itself. 

    Can you please say what kind of an error you were getting in Inkscape?

    Also, is there any chance that you could try on another computer, just in case there's something specifically blocking access on that one?
  • Inkscape worked first time :)
    I installed the 1.1 extension, selected the WaterColorBot extension, put on a swirl on the black layer, selected apply, and it painted a swirl (OK, I didn't have a brush in yet :) ).  
  • I'll try to test on my laptop in the coming days to see if I can get RoboPaint to work on it. I would also like to try on a Raspberry Pi, but the steps seem a little daunting at the moment.
  • OK great-- progress finally. The machine, and its connection to your computer are clearly working. However, you seem to have discovered a new issue with RoboPaint-- I am still trying to find additional things that we can test there to see if we can figure out what's going on. Did you get a chance to try with one of the older beta versions? 
  • There is a "developer mode" within RoboPaint. If you can open that up, perhaps there are some error messages there that might help to clarify things. In RoboPaint Settings, under Advanced, there is a "Misc" option to enable RoboPaint Debug/Developer features. With that turned on, you should see a console, and possibly some error messages listed.
Sign In or Register to comment.