Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Newbie... Help...

edited December 2016 in Egg-Bot
I just setup my EBP this morning and noticed that on most, if not all, test plots I have done the EBP does not complete the entire drawing. Example, I just did the "Merry Christmas" outline from the examples (GitHub) and the tops of several letters did not complete.  The pen never went to those spaces, so it was not a pen issue.  Now when it retraced the letters it competed a few of them, but not all.  This was on a 2 5/8" frosted Christmas tree ornament. 
What am I doing wrong?  I have tried the Honeycomb pattern on an egg and it did not complete it properly and did not always lift the pen completely before going to the next line.

I already love this machine... I have some good ideas, but I have to be able to compete a plot before moving forward. 
Thanks in advance for any help!  


  • I'm not sure that I can understand exactly what is going wrong from that description. If part of a letter draws, but the top does not, perhaps you could watch a little more closely and see exactly what is going on there. Did the pen actually *lift up* (i.e., with a movement of the pen lift motor), or was it simply not touching the ornament there? 

    Most likely, the pen tried to go there, but was not set at the right position over the full curvature of the ornament.  Please see section "4.5 Inserting a pen, and checking alignment" in the EggBot Pro user guide-- you likely need to adjust the position of the pen holder. For spheres (like ornaments) the vertical pen position should be set fully up (see section 4.4), and the horizontal position should be set according to the chart in section 5.5, to make sure that it neatly traces over the full arc.  

    I say "most likely" because you have indicated separately that the pen position is not in the right place. If the pen does not lift completely in some places, that indicates that the pen holder position is not correct. Again, see the chart in section 4.5.
  • Thanks Windell... I will check it out again. Here is link to a photo... Notice the r and the i as well as the t.  

  • Yes, looks like a pen height issue. Try plotting more slowly as well, until you are up to speed (pun intended), and know how to watch its behavior a little more easily.
  • Windell - Should I be able to login to the forums without using the MES link? So far I cannot. I have to use the MES option.
  • I don't think that I've heard of MES; what is that?
  • Sorry. It was supposed to me EMS... Evil Mad Scientist not Mad Evil Scientist. 
    When the forum sign in screen displays it gives options. Direct sign in, which does not work and the "Sign in with: Evil Mad Scientist". 

  • Yes, you need to sign in with Evil Mad Scientist to post here.
  • One more thing... I noticed last night that the pen motor is not returning to vertical.  It is a few degrees right (looking from the front (pen side). I powered off and on.  I have not looked to see if there are "reset" or default settings.  Or does it matter?  

    BTW, I am having successes and love the EBP. 

    Thanks for your help.  
  • Every time that you remove and apply power again, you will need to set the initial pen position. When power is first applied, the motor will "snap" into position, which may be up to one degree away from where you initially set it -- typically about 1 mm of apparent horizontal movement.
  • edited December 2016
    I am so frustrated!  Creating SVG files is a royal pain.  I created a file using Graphic (Autodesk) iOS version. I opened it and fixed the font (Inkscape did not have the font). I drew the other elements in Graphic, which appear to be done correctly as a path and get the message... 
    Warning: unable to draw bitmap images; please convert them to line art first.  Consider using the "Trace bitmap..." tool of the "Path" menu.  Mac users please note that some X11 settings may cause cut-and-paste operations to paste in bitmap copies.
    ITS not a bitmap.... 
    I thought I read all there is concerning creating files, but this is about to make me put this thing on the shelf until someone way smarter than me comes up with an app that says - "do what you want" and I will make it Eggbot ready!  
    Help! Perhaps I could send the file to someone to help me fully understand what is going on. 
    Even the layer that has only text from Inkscape gives me the error above.   
  • edited December 2016
    You're trying something that (in all likelihood) no one has ever done before; I'm not surprised in the least that you are finding it frustrating.

    I haven't heard of Graphic before, nor seen a file that it generates. And, regardless of whether or not it uses vectors for drawing paths, you also need to be able to export them into a vector file format that Inkscape understands. 

    Inkscape does not have _any_ fonts-- it only uses the ones on your computer. If you need to have font interoperability between Inkscape and whatever other program you're using, you'll need to have that font installed on your computer. (This is the exact same thing that would be true of any other program that uses fonts.) If you cannot install this font on your computer, then I'd suggest converting your text from into vectors before exporting.

    The "bitmap" warning is triggered any time that there is an image file within your document. And, it won't be triggered unless there is an image file there.  As I haven't ever seen a file created in Graphic, I do not know what kind of an image is in there, nor whether there is any vector content in addition to the image.

    If you would like to send us your SVG file (and possibly the original file that you exported from Graphic), please contact customer service directly. We might be able to provide some insight.

Sign In or Register to comment.