Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Eggbot help for the newbe

edited March 2017 in Egg-Bot
I installed the drivers and Inkscape software. I hooked up my eggbot and the computer USB seems to see it. But when I try to run anything in "eggbot "control, setup" in Inkscape, it returns this error.

Traceback (most recent call last):
  File "", line 1406, in <module>
  File "C:\Program Files\Inkscape\share\extensions\", line 283, in affect
  File "", line 314, in effect
  File "", line 1299, in EggbotOpenSerial
    self.serialPort = self.getSerialPort()
  File "", line 1356, in getSerialPort
    for strComPort in eggbot_scan.findEiBotBoards():
  File "C:\Program Files\Inkscape\share\extensions\", line 6, in findEiBotBoards
    hKey = _winreg.OpenKey( hReg, r"SYSTEM\CurrentControlSet\Enum\USB\VID_04D8&PID_FD92" )
WindowsError: [Error 2] The system cannot find the file specified

I have tried to find the file it is referencing at the end "VID_04D8&PID_FD92" with no luck. Am I correct in assuming I need a copy of this file, and where do I get it if I do?

I am running Windows 7 Pro

Thanks in advance for any help you can give.


  • Can you please say which version of the EggBot software you are using?
  • 2.7.1, I was using 2.5... but I updated it after I posted, when I looked (I thought I was running the newest one)... and now I am just getting a "Failed to connect to EggBot. :(" error... so I am not sure what is happening.. thanks

    Sorry for the slow reply.. 
  • I'd suggest manually running the driver installer (UBW Driver Installer), available separately with the 2.7.1 release.

    You might also try a different USB cable, just in case.
  • Thanks... I will try this

  • edited March 2017
    Tried to run the installer again... also reloaded the eggbot software extension... both the 2.4 and the 2.7.1 versions (separately)... and I got nowhere with it... the 2.4 version gave me the long error report in my first post... and the 2.7.1 gives me the failed to connect... and the computer sees the eggbot... and the drivers seem to be correct in the device manager....

    I also installed the 32bit version... after I got rid of the other... still nothing new.. even with the new cord..

    Any ideas... I believe this has to be in the software... but I have no idea where to start... 
  • The "file" that it is looking for is the USB address of the EBB control board. So, the error message is really saying "I can't find this USB device", although it is failing in an unusual manner, and thus gets a rather cryptic error message.

    You're re-installing lots of things, which is one of those ways that unexpected things can go wrong. I'm not sure which version(s) you're on now, but let's try and take this from the top.

    I presume that you have successfully installed the driver (in at least one of those attempts), so we shouldn't need to worry about that.

    1): I'd like to recommend that you run the EBB firmware updater, which should update the EBB to firmware version 2.5.1. If this works, it will also (more importantly) establish that your computer has a good and functional USB connection to the EBB. You can download the updater program from:

    2): Let's make sure that your Inkscape install is in good shape. First, remove any installed versions of Inkscape that you do have. (Having multiple copies of Inkscape on your computer is a common cause of various issues.) Since your computer is 64-bit, I'd highly recommend using the 64-bit version of Inkscape, and please stick with Inkscape version 0.91. You'll want the "Windows : 64-Bit : Msi" installer version from the Inkscape 0.91 download page at:
    (If you have already downloaded this, please go ahead and install the same copy that you downloaded previously.)

    3): Verify that this is a fresh copy of Inkscape by checking to see that EggBot _does not_ occur in your Inkscape extensions menu.  Then, test to make sure that your extensions are working (in general) by trying Extensions > Render > Gear.

    4): Download the newest version of the EggBot software (version 2.8.0), from here:

    This version will need to be _manually_ installed. Follow the directions at that link for "Windows users" about how to install it.

    5): Restart Inkscape, and see if you can connect to the EggBot.

    If you should get stuck at any point along this process, please let me know where, and we'll take it from there. I'd like to get to the bottom of it.
  • Thanks.. give me a little while... I will get back to you one way or the other...
  • I ran the EBB firmware updater... nothing... the updater does not find the board... this board is one made by JJrobots... I don't know if that will matter... the EBB firmware updater seems to be looking for the board on the correct com port... but fails to find anything... I disconnected everything from the EBB.. all that is hooked up is the Ardino and the EBB...

    Any Ideas?
  • That does make a big difference. We only provide technical support for products that we make and sell. You'll have to talk to the manufacturer about it.
  • Thanks for all your help... sorry I was not clearer from the start... BTW... if you don't mind giving a last bit of help... is the EBB firmware updater compatible with other boards... or does the fact it does not find mine really mean very little?

    Thanks again for your help with this...
Sign In or Register to comment.