lxml wrapper needed after upgrading inkscape to 0.92

I upgraded to 2.8b and have reinstalled the latest UBW drivers. I am running Win7 64bit.

After upgrading inkscape I am not getting the following message when I click on the apply button to try to do any function with the eggbot.

The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension.Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml

Technical details:
No module named lxml

Thanks for the help

Comments

  • We are still not recommending 0.92 for various reasons. (We'd still generally advise to stick with 0.91 for the moment.)

    We have heard of this particular error three times in recent memory, and on Windows only. It appears to be due to a conflict on your system about where the python "home" directory is located. One workaround that we have seen work is to edit your environment variables, and remove the one called PythonHome.

    This guide shows you how to access and edit your environment variables in Windows 7:
    https://www.nextofwindows.com/how-to-addedit-environment-variables-in-windows-7

  • I uninstalled .92 and I will see if I can find .91
    Thanks

  • I installed .91 and I am back to where I was when I upgraded to .92. I can see the arduino uno in device manager - USB-SERIAL CH340 (COM3) but when I try to connect using the eggbot extension in inkscape I get "Failed to connect to EggBot. :("

  • Good; that resolves the LXML issue.

    As far as the rest goes, that's not one used by either Arduino or EggBot, so you might be on your own.

  • it is the arduino. it disappears when I unplug it and reappears when plugged back in. I have tried two different USB cables. I also tried a different uno and it came up the same. I am guessing this has to do with the ubw driver

  • So far as I know, no actual Arduino ever used the CH340 -- just some cheap knockoffs. In any case, this support forum is for EggBot, so I'm closing this topic.

This discussion has been closed.