Engraver will not start help needed

Inkscape .91
AxiDraw Control 1.0.2
EggBot Control 2.7.1
EBB v13 EB Firmware 2.5.1
MacOS 10.13.2

I am having an issue getting the engraver to come on.
I have it enabled in the 'options' menu.
Plugged into the top 'B3'connector. "-" towards the outside of the board.
Tried both the manual 'on' and plot functions with no luck.

Originally I thought it was because I was using .92 version of Ink Scape but today I had the chance to load up .91.
Both versions work fine for both EggBot and AxiDraw plotting but no engraver in EggBot.

Merry Christmas
Craig

Comments

  • First up, double chec that the option is enabled. Then, start a lengthy plot with the engravr plugged in. (You may wish to fully remove the pen arm before doing this, so that it’s not swinging around.) While the plot is still going, try adjusting thr current adjustment pot on the engraver board, through the full range of motion available.

    Is this the soldering kit version of the engraver, or one that came pre-assembled?

  • Hi Windell I have tried the pot with no luck…and no this is not the soldering kit…Options 'enable engraver' checked.
    A little more info, I originally purchased the wrong engraver Ostrich not pro.
    I have sense received the correct engraver. I thought maybe there was a difference between them. What I’m saying is neither one worked.

  • It's possible that there's a hardware issue on the EggBot's EBB driver board that is preventing the correct output signal from getting where it needs to. A thing that you could try as a test -- quite non-traditional but possibly effective -- would be to try driving the engraver from the AxiDraw. Place the AxiDraw in the very middle of its travel in both X and Y (halfway to the right, halfway extended), hook up the engraver to the AxiDraw's EBB (in the same location) and try plotting with the EggBot software, to see if you can get it to run from that machine. Please let me know what you find.

  • Running EggBot with AxiDraw did not bring on the engraver so no change.

    I next tried starting from scratch by reloading InkScape, AxiDraw and EggBot testing as I went along. I think I may have identified another issue.

    Loading InkScape first with AxiDraw plots with no problem.
    Load EggBot and trying to plot with AxiDraw and AxiDraw control I get the following error:

    Traceback (most recent call last):
    File "axidraw.py", line 2076, in
    e.affect()
    File "/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/inkex.py", line 268, in affect
    self.effect()
    File "axidraw.py", line 254, in effect
    self.plotDocument()
    File "axidraw.py", line 496, in plotDocument
    if (not self.getDocProps()):
    File "axidraw.py", line 2066, in getDocProps
    self.svgHeight = plot_utils.getLengthInches( self, 'height' )
    AttributeError: 'module' object has no attribute 'getLengthInches'

    So as soon as I load EggBot software I lose control of Axidraw.
    Plotting with EggBot and EggBot control are working.
    Further testing both Ostrich and Pro engravers are still not working on either AxiDraw or EggBot. (I have not returned the one as yet.)

    Cheers and thanks for your help

  • What I had intended to suggest is that you open an EggBot File, and try to plot it with the EggBot software with its engraver control enabled, but while connected to the AxiDraw (and, critically, with the AxiDraw at the middle of travel in both X and Y). Would you please give that a try?

    Side note: The error message that you received is normal and expected (though ugly, and nicer looking in forthcoming versions) -- it's what I'd expect you to get if you try to plot an EggBot file with AxiDraw Control.

  • Sorry I should have elaborated - yes I did run an EggBot drawing with eggBot control engraver enabled on the AxiDraw and the engraver did not work, tried both engravers.

    Regarding the error...I am using an AxiDraw drawing using AxiDraw control on the AxiDraw.
    So my statement on no longer being able to use AxiDraw after loading EggBot stands.

  • The error essentially says that the document needs to have physical units -- typically inch or cm units. EggBot Documents, formatted in pixel dimensions, are a good example of a document that does not have physical units.
    Try creating a new document (for example A4 or letter size), by using File > Templates.

    On the engraver issue, please follow up with us by e-mail; we'd like to do some more in depth debugging than is straightforward through the forum.

  • Thanks Windell I will follow up with email...
    When starting from scratch (re-loading everything) I was able to draw an AxiDraw file as described.
    It wasn't until I loaded the EggBot control that I lost the ability to draw using AxiDraw.

    Merry Christmas

Sign In or Register to comment.