Maintenance notice: These forum archives are read-only, and will be removed shortly. Please visit our forums at their new location,

Error reading serial data.

edited October 2012 in Egg-Bot
I keep getting this error. I've got Inkscape 48.2 r9819, Extnsios 2.21EBB firmware V13 2.0.2. Everything stats to work from EggBot Control then?


  • I'm not sure what you mean by "Everything stats to work from EggBot Control then?"

    Can you say what operating system you're using?  And, is this the firmware that your EBB originally shipped with?
  • Win XP and I only updated the firmware after exasperation!
  • We generally do not recommend updating the firmware, unless you need some of the specific features that are in the newer versions-- the version that ships with the EBB is extremely reliable and well-understood, which is why we've continued to use it.  

    Now, when you get this error, is it on its own, or are you actually getting the "unable to find an eggbot..." error first?  
  • Pardon my confusion, I just meant to say I sucessfully installed inkscape, the Extensions and USB drivers. I have also connected sucessfully with the eggbot using the egg-bot controll panel. Individual commands occasionally work but a plot command will stop quite quickly. Thankyou in advance for any help you can offer


  • Hmm.  Likely a hardware issue, then.  

    Check the EBB to see if there are any signs of damage.  Try a different USB cable if you have one.  Check the power supply to see if there's any damage to its plug.  See if you can make the problem worse (or better) by holding the USB cable one way or another, and the same with the power supply.
  • Thanks. Those are good ideas. I'll reset the firmware too if needed. But alas, dinner calls! More later. Thank you
  • WOW had to download a new browser to get back here. I Have tried many things including cords and various EBF files. The serial read error keeps popping up. about 50% of command tries. A window opens with: Inkscape has received additional data from the script executed.  The script did not return an error, but this may indicate the results will not be as expected. In the small 'sub' window it says:

     Error reading serial data.
    Traceback (most recent call last):
      File "", line 1403, in <module>
      File "I:\Program Files\Inkscape\share\extensions\", line 215, in affect
      File "", line 315, in effect
      File "", line 497, in setupCommand
      File "", line 1172, in ServoSetupWrapper
        if strVersion[0] == '0':
    IndexError: string index out of range

    This occurred after applying a 'toggle pen' command in eggbot control/setup. The first few times worked fine then error!

  • Hey I have an idea! I'll send it to my brother so he can try it out. He's got one too and is responsible for getting me started. He's also an electronics engineer!
    My brother is pretty sharp! Turns out I have too long of a USB connection. We have a hub under the coffee table and access the system in the closet. Too many hubs in a row (2) and a 25 foot extension. Plugged directly into computer it works perfectly. Thanks Windell for your help. I believe you did ask me to try other connection options!! 
    Doug (eggdag)
  • Fantastic-- I'm glad to hear that there's a good explanation for what went wrong, too!
Sign In or Register to comment.